Bug 1577140 - [svcat] command outputs the result differently
Summary: [svcat] command outputs the result differently
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Marko Luksa
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 09:57 UTC by sunzhaohua
Modified: 2018-07-30 19:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:15:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:53 UTC

Description sunzhaohua 2018-05-11 09:57:40 UTC
Description of problem:
command outputs the result differently.


Version-Release number of selected component (if applicable):
svcat:
client: v3.10.0-0.38.0;Upstream:v0.1.16
server: v1.10.0+b81c8f8


How reproducible:
Always

Steps to Reproduce:
1. check command result information

Actual results:
the command outputs the result differently. For example:
# svcat provision
Error: an instance name is required
# svcat deprovision
Error: name is required (should change to "an instance name")
# svcat bind
Error: instance is required (should change to "an instance name")
# svcat unbind
Error: an instance or binding name is required
# svcat sync broker
Error: name is required (should change to "a broker name")
# svcat touch instance
Error: an instance name is required


Expected results:
the output information should show in the same way.

Additional info:

Comment 1 Marko Luksa 2018-05-16 12:49:14 UTC
PR submitted: https://github.com/kubernetes-incubator/service-catalog/pull/2038

Comment 2 Marko Luksa 2018-05-17 13:28:14 UTC
PR has been merged.

Comment 4 sunzhaohua 2018-05-22 09:40:41 UTC
 image is ready, change it to ON-QA

Comment 5 sunzhaohua 2018-05-22 09:41:45 UTC
# svcat version
client: v3.10.0-0.50.0;Upstream:v0.1.19
server: v1.10.0+b81c8f8

# svcat provision
Error: an instance name is required
# svcat deprovision
Error: an instance name is required
# svcat bind
Error: an instance name is required
# svcat unbind
Error: an instance or binding name is required
# svcat sync broker
Error: a broker name is required
# svcat touch instance
Error: an instance name is required

Comment 7 errata-xmlrpc 2018-07-30 19:15:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.