Bug 1577143 - Inconsequently values for prefork mode of apache
Summary: Inconsequently values for prefork mode of apache
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: php
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Remi Collet
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 10:10 UTC by Frank Büttner
Modified: 2021-01-14 09:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-07 14:34:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Frank Büttner 2018-05-11 10:10:45 UTC
Description of problem:
In the file /etc/httpd/conf.modules.d/10-php.conf, the php module is only loaded on prefork mode of apache. This is ok, because mod_php will only work on this.

But at /etc/httpd/conf.d/php.conf this protection is missing.
So an apache which is not using prefork will not start, because the module options in this file are invalid. (mod php is not load) 



Version-Release number of selected component (if applicable):
php-5.4.16-45.el7.x86_64

How reproducible:
Using apache in worker mode


Steps to Reproduce:
1. install the php package
2. try to start the apache

Actual results:
Apache can't start


Expected results:
running apache

Additional info:
Remove the package will not work, because other package will install it as an dependency. Also when apache use php via fpm.
So I think the whole config in  /etc/httpd/conf.d/php.conf must enclosed with <IfModule prefork.c> </IfModule>

Comment 3 Joe Orton 2018-11-07 14:34:03 UTC
This is not a bug, it is an expected configuration error if php is installed but can't be loaded.  Silently serving .php files as plain text rather than interpreting them is not desired if the module was not loaded for some reason.


Note You need to log in before you can comment on or make changes to this bug.