Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1577144 - ASB logs error about problem reading job state when deprovision
Summary: ASB logs error about problem reading job state when deprovision
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Shawn Hurley
QA Contact: Zihan Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 10:12 UTC by Zihan Tang
Modified: 2018-12-20 21:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-12-20 21:12:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1583587 0 medium CLOSED ASB logs error about could not find instance when deprovision 2021-02-22 00:41:40 UTC

Internal Links: 1583587

Description Zihan Tang 2018-05-11 10:12:42 UTC
Description of problem:
When deprovision ,ASB logs error : 
[2018-05-11T10:04:10.526Z] [ERROR] - Could not find instance c3b999df-54f7-11e8-971f-0a580a800003 associated with job state 8fd3cd84-9409-4506-9dae-e81c72313eb3 - bundleinstances.automationbroker.io "c3b999df-54f7-11e8-971f-0a580a800003" not found
[2018-05-11T10:04:10.526Z] [ERROR] - problem reading job state: [c3b999df-54f7-11e8-971f-0a580a800003]. error: [bundleinstances.automationbroker.io "c3b999df-54f7-11e8-971f-0a580a800003" not found]


Version-Release number of selected component (if applicable):
1.2.10

How reproducible:
always
Steps to Reproduce:
1. provision a apb like postgresql 
2. deprovision the serviceinstance ,check the asb  log 

Actual results:
deprovision succeed. but asb logs error:
[2018-05-11T10:04:10.526Z] [ERROR] - Could not find instance c3b999df-54f7-11e8-971f-0a580a800003 associated with job state 8fd3cd84-9409-4506-9dae-e81c72313eb3 - bundleinstances.automationbroker.io "c3b999df-54f7-11e8-971f-0a580a800003" not found
[2018-05-11T10:04:10.526Z] [ERROR] - problem reading job state: [c3b999df-54f7-11e8-971f-0a580a800003]. error: [bundleinstances.automationbroker.io "c3b999df-54f7-11e8-971f-0a580a800003" not found]

Expected results:
no errors when deprovision 

Additional info:

Comment 1 Shawn Hurley 2018-05-14 16:45:29 UTC
PR: https://github.com/openshift/ansible-service-broker/pull/949

This will change the log statement about job state to be a Warning as well as update the message to be more clear.

Comment 3 Zihan Tang 2018-05-22 06:05:30 UTC
Image is ready, change it to ON_QA.

Comment 4 Zihan Tang 2018-05-22 06:08:03 UTC
Verify failed.

Only 1 ERROR log changed to WARNING.  

the first line is still in ERROR.

[2018-05-22T05:55:56.41Z] [ERROR] - Could not find instance 16a03b07-5d71-11e8-8814-0a580a800004 associated with job state 23a48153-246d-4772-884a-d903f8a3fd88 - bundleinstances.automationbroker.io "16a03b07-5d71-11e8-8814-0a580a800004" not found
[2018-05-22T05:55:56.41Z] [WARNING] - unable to find job state: [16a03b07-5d71-11e8-8814-0a580a800004]. error: [bundleinstances.automationbroker.io "16a03b07-5d71-11e8-8814-0a580a800004" not found]

Comment 5 Shawn Hurley 2018-05-23 12:18:03 UTC
I don't think that we will be changing that log statement.

We will work on a better way to log these statements in the next release but we are not going to change this one. The reason being the DAO just has a single get method. This method will actually be in error state if you can not find the instance 9/10 times. We have no way to selectively turn off the log statement just of a single call of the method. 

@John is the above correct?

Comment 6 John Matthews 2018-05-24 19:18:32 UTC
For 3.10 we only intend to change the 1 message Shawn mentioned.

Open to considering an alternative approach to reduce the first ERROR message, if that is interesting then please file a new BZ for that message and we can consider for 3.11.

Comment 7 Zihan Tang 2018-05-29 09:56:18 UTC
Based on comment6 & comment 4 , mark this as Verified.
I'll open another bug for 3.11 to trace the other error message.


Note You need to log in before you can comment on or make changes to this bug.