Bug 1577158 - [RFE] UI does not take text constraints into consideration
Summary: [RFE] UI does not take text constraints into consideration
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: ---
Assignee: Honza Pokorny
QA Contact: Arik Chernetsky
URL:
Whiteboard: NeedsAllocation
: 1577160 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 11:08 UTC by Amit Ugol
Modified: 2019-11-04 03:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-04 03:29:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Amit Ugol 2018-05-11 11:08:27 UTC
Description of problem:
Deploying VIA UI, it is possible to change a textbox setting to whatever because UI does not take constraints into considerations.

Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Via UI open a plan and navigate to settings.
2. Select a constraint setting that has a textbox input and change it to something outside of the constraint
3.click on save.

Actual results:
Setting was saved.


Expected results:
Setting outside the constraint cannot be saved.


Additional info:
Tested with "flowers" on the ceiloemter debug setting.

  CeilometerDebug:
    default: ''
    description: Set to True to enable debugging Ceilometer services.
    type: string
    constraints:
      - allowed_values: [ '', 'true', 'True', 'TRUE', 'false', 'False', 'FALSE']

Comment 2 Honza Pokorny 2018-05-23 14:42:53 UTC
*** Bug 1577160 has been marked as a duplicate of this bug. ***

Comment 5 Jason E. Rist 2019-11-04 03:29:23 UTC
This will no longer be worked on since TripleO-UI is deprecated upstream.


Note You need to log in before you can comment on or make changes to this bug.