Bug 1577214 - Add librdkafka to comps file for release
Summary: Add librdkafka to comps file for release
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
: 1584168 (view as bug list)
Depends On:
Blocks: 1485931 1568427
TreeView+ depends on / blocked
 
Reported: 2018-05-11 13:30 UTC by Eng Ops Maitai User
Modified: 2019-01-29 11:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 07:21:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3014 0 None None None 2018-10-30 07:22:39 UTC

Comment 2 Lubos Kocman 2018-05-11 14:15:58 UTC
Please be aware that until rsyslog-kafka is build and attached to advisory the package librdkafka will not end up in compose at all nor will have filelists in errata.

Comment 4 Lubos Kocman 2018-05-30 12:55:15 UTC
*** Bug 1584168 has been marked as a duplicate of this bug. ***

Comment 5 Lubos Kocman 2018-05-30 13:03:25 UTC
Added rsyslog-kafka to @base and @network-server next to rsyslog-* also skipped @core as rsyslog is mandatory there.


https://code.engineering.redhat.com/gerrit/gitweb?p=comps.git;a=commit;h=031d60a56fdd1003b407c48a73f2ca15ecf42f63

Comment 6 Alexander Todorov 2018-07-09 12:44:35 UTC
(In reply to Lubos Kocman from comment #5)
> Added rsyslog-kafka to @base and @network-server next to rsyslog-* also
> skipped @core as rsyslog is mandatory there.
> 
> 
> https://code.engineering.redhat.com/gerrit/gitweb?p=comps.git;a=commit;
> h=031d60a56fdd1003b407c48a73f2ca15ecf42f63

rsyslog-kafka not in comps for RHEL-7.6-20180626.0. 

rsyslog-kafka and librdkafka are both in the optional repositories.

Comment 8 Lubos Kocman 2018-08-01 12:33:39 UTC
Moving back to QE if it's dependency driven we just let depsolving define the placement.


lkocman@rcm-dev:rhel-7.6> locate-rhel7-rpms librdkafka
Searching in /mnt/redhat/nightly/latest-RHEL-7/
Client/x86_64/os/Packages/librdkafka-0.11.4-1.el7.i686.rpm
Client/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
Client/x86_64/os/Packages/librdkafka-0.11.4-1.el7.x86_64.rpm
Client/x86_64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.i686.rpm
Client/x86_64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.x86_64.rpm
Client-optional/x86_64/os/Packages/librdkafka-devel-0.11.4-1.el7.i686.rpm
Client-optional/x86_64/os/Packages/librdkafka-devel-0.11.4-1.el7.x86_64.rpm
ComputeNode/x86_64/os/Packages/librdkafka-0.11.4-1.el7.i686.rpm
ComputeNode/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
ComputeNode/x86_64/os/Packages/librdkafka-0.11.4-1.el7.x86_64.rpm
ComputeNode/x86_64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.i686.rpm
ComputeNode/x86_64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.x86_64.rpm
ComputeNode-optional/x86_64/os/Packages/librdkafka-devel-0.11.4-1.el7.i686.rpm
ComputeNode-optional/x86_64/os/Packages/librdkafka-devel-0.11.4-1.el7.x86_64.rpm
Server/ppc64/os/Packages/librdkafka-0.11.4-1.el7.ppc.rpm
Server/ppc64/os/Packages/librdkafka-0.11.4-1.el7.ppc64.rpm
Server/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
Server/ppc64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.ppc.rpm
Server/ppc64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.ppc64.rpm
Server/ppc64le/os/Packages/librdkafka-0.11.4-1.el7.ppc64le.rpm
Server/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
Server/ppc64le/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.ppc64le.rpm
Server/s390x/os/Packages/librdkafka-0.11.4-1.el7.s390.rpm
Server/s390x/os/Packages/librdkafka-0.11.4-1.el7.s390x.rpm
Server/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
Server/s390x/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.s390.rpm
Server/s390x/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.s390x.rpm
Server/x86_64/os/Packages/librdkafka-0.11.4-1.el7.i686.rpm
Server/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
Server/x86_64/os/Packages/librdkafka-0.11.4-1.el7.x86_64.rpm
Server/x86_64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.i686.rpm
Server/x86_64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.x86_64.rpm
Server-optional/ppc64/os/Packages/librdkafka-devel-0.11.4-1.el7.ppc.rpm
Server-optional/ppc64/os/Packages/librdkafka-devel-0.11.4-1.el7.ppc64.rpm
Server-optional/ppc64le/os/Packages/librdkafka-devel-0.11.4-1.el7.ppc64le.rpm
Server-optional/s390x/os/Packages/librdkafka-devel-0.11.4-1.el7.s390.rpm
Server-optional/s390x/os/Packages/librdkafka-devel-0.11.4-1.el7.s390x.rpm
Server-optional/x86_64/os/Packages/librdkafka-devel-0.11.4-1.el7.i686.rpm
Server-optional/x86_64/os/Packages/librdkafka-devel-0.11.4-1.el7.x86_64.rpm
Workstation/x86_64/os/Packages/librdkafka-0.11.4-1.el7.i686.rpm
Workstation/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
Workstation/x86_64/os/Packages/librdkafka-0.11.4-1.el7.x86_64.rpm
Workstation/x86_64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.i686.rpm
Workstation/x86_64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.x86_64.rpm
Workstation-optional/x86_64/os/Packages/librdkafka-devel-0.11.4-1.el7.i686.rpm
Workstation-optional/x86_64/os/Packages/librdkafka-devel-0.11.4-1.el7.x86_64.rpm
Searching in /mnt/redhat/nightly/latest-Supp-7-RHEL-7/
Searching in /mnt/redhat/nightly/latest-BUILDROOT-7-RHEL-7/

lkocman@rcm-dev:rhel-7.6> locate-pegas-rpms librdkafka
Searching in /mnt/redhat/nightly/latest-RHEL-ALT-7/
Server/aarch64/os/Packages/librdkafka-0.11.4-1.el7.aarch64.rpm
Server/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
Server/aarch64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.aarch64.rpm
Server/ppc64le/os/Packages/librdkafka-0.11.4-1.el7.ppc64le.rpm
Server/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
Server/ppc64le/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.ppc64le.rpm
Server/s390x/os/Packages/librdkafka-0.11.4-1.el7.s390.rpm
Server/s390x/os/Packages/librdkafka-0.11.4-1.el7.s390x.rpm
Server/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
Server/s390x/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.s390.rpm
Server/s390x/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.s390x.rpm
Server/x86_64/os/Packages/librdkafka-0.11.4-1.el7.i686.rpm
Server/source/tree/Packages/librdkafka-0.11.4-1.el7.src.rpm
Server/x86_64/os/Packages/librdkafka-0.11.4-1.el7.x86_64.rpm
Server/x86_64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.i686.rpm
Server/x86_64/debug/tree/Packages/librdkafka-debuginfo-0.11.4-1.el7.x86_64.rpm
Server-optional/aarch64/os/Packages/librdkafka-devel-0.11.4-1.el7.aarch64.rpm
Server-optional/ppc64le/os/Packages/librdkafka-devel-0.11.4-1.el7.ppc64le.rpm
Server-optional/s390x/os/Packages/librdkafka-devel-0.11.4-1.el7.s390.rpm
Server-optional/s390x/os/Packages/librdkafka-devel-0.11.4-1.el7.s390x.rpm
Server-optional/x86_64/os/Packages/librdkafka-devel-0.11.4-1.el7.i686.rpm
Server-optional/x86_64/os/Packages/librdkafka-devel-0.11.4-1.el7.x86_64.rpm

Comment 12 errata-xmlrpc 2018-10-30 07:21:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3014


Note You need to log in before you can comment on or make changes to this bug.