Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1577231 - Emergency mode does not work
Summary: Emergency mode does not work
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 14:02 UTC by Daniel Rusek
Modified: 2018-05-24 11:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-24 11:59:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Daniel Rusek 2018-05-11 14:02:39 UTC
Description of problem:
When booting into the emergency mode, boot process hangs. There is no password prompt shown, only blinking text cursor.

Version-Release number of selected component (if applicable):
initscripts-9.49.41-1.el7.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. grubby --update-kernel=ALL --args=emergency
2. reboot

Actual results:
System hangs during boot.

Expected results:
System boots into the emegency mode and single-user password prompt is shown.

Comment 2 David Kaspar [Dee'Kej] 2018-05-11 14:10:45 UTC
initscript no longer take care of emergency mode / password reprompt in RHEL-7+. Switching to systemd...

Comment 3 Daniel Rusek 2018-05-11 15:11:07 UTC
More info:

systemd-219-57.el7.x86_64
plymouth-0.8.9-0.31.20140113.el7.x86_64

Kernel version: 3.10.0-862.el7.x86_64

Kernel cmdline: BOOT_IMAGE=/vmlinuz-3.10.0-862.el7.x86_64 root=/dev/mapper/rhel_pes--guest--73-root ro crashkernel=auto rd.lvm.lv=rhel_pes-guest-73/root rd.lvm.lv=rhel_pes-guest-73/swap console=ttyS0,115200 LANG=en_US.UTF-8 emergency

I use clean rhel-7.5 system scheduled by beaker. I also tried this in the openstack rhel-7.5 image - same issue.

Comment 4 Daniel Rusek 2018-05-11 15:24:15 UTC
There's the same issue if there is a bad entry in fstab. Systemd sulogin prompt is not shown and boot process hangs.

Comment 5 Lukáš Nykrýn 2018-05-14 11:33:16 UTC
I've tried this with the virtual machine and fresh new 7.5 and it seems to work just fine.

Are you sure that your console is set up properly? It really matters in this case.

[  261.121197] Restarting system.
Welcome to emergency mode! After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to
try again to boot into default mode.
Pro zah?jen? ?dr?by je t?eba zadat heslo u?ivatele root
(nebo stiskn?te Control-D, abyste pokra?ovali): 
[root@localhost ~]# cat /etc/os-release 
NAME="Red Hat Enterprise Linux Server"
VERSION="7.5 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Server"
VARIANT_ID="server"
VERSION_ID="7.5"
PRETTY_NAME="Red Hat Enterprise Linux Server 7.5 (Maipo)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.5:GA:server"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.5
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.5"
[root@localhost ~]# rpm -q systemd
systemd-219-57.el7.x86_64
[root@localhost ~]# uname -a
Linux localhost.localdomain 3.10.0-862.el7.x86_64 #1 SMP Wed Mar 21 18:14:51 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost ~]# cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.10.0-862.el7.x86_64 root=/dev/mapper/rhel-root ro crashkernel=auto rd.lvm.lv=rhel/root rd.lvm.lv=rhel/swap rhgb quiet LANG=cs_CZ.UTF-8 emergency console=ttyS0
[root@localhost ~]# tty
/dev/ttyS0

Comment 6 Daniel Rusek 2018-05-24 11:48:37 UTC
You're right! I have just tried it in a RHEL 7.5 VM in KVM and it works fine. So it seems to be an issue with our VNC and serial remote consoles. Feel free to close this bz.


Note You need to log in before you can comment on or make changes to this bug.