Bug 1577234 - Telegram hangs with fontconfig
Summary: Telegram hangs with fontconfig
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 14:13 UTC by NSLW
Modified: 2018-05-16 12:58 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-16 12:58:06 UTC
Type: Bug


Attachments (Terms of Use)
Terminal output (47.83 KB, text/plain)
2018-05-11 14:13 UTC, NSLW
no flags Details

Description NSLW 2018-05-11 14:13:11 UTC
Created attachment 1434939 [details]
Terminal output

Description of problem:
Telegram hangs

Version-Release number of selected component (if applicable):
tsetup.1.2.17.tar.xz

How reproducible:
always

Steps to Reproduce:
1. start Telegram
2.
3.

Actual results:
Hang up.

Expected results:
No hang up.

Additional info:

Comment 1 Akira TAGOH 2018-05-16 12:58:06 UTC
This is basically NOTOURBUG because Telegram statically links older fontconfig. what you have options so far is to ask Telegram to update Telegram with fontconfig 2.13 at least or ideally stop statically linking fontconfig in their application.

If you can't wait for their action, you could do take this workaround, copy fonts.conf to $HOME/.config/fontconfig and update the line like '<include ignore_missing="yes">conf.d</include>' to the location where you put the older config files shipped in 2.12.6 or before. e.g. <include ignore_missing="yes">/path/to/fontconfig-2.12.6/conf.d</include>


Note You need to log in before you can comment on or make changes to this bug.