Bug 1577266 - blivet.errors.LUKSError: luks device not configured
Summary: blivet.errors.LUKSError: luks device not configured
Keywords:
Status: CLOSED DUPLICATE of bug 1624617
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Blivet Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ecedb09c3431d9293f1e7160f01...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 15:01 UTC by Jérôme Glisse
Modified: 2018-09-27 09:19 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-27 09:19:55 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (1.43 MB, text/plain)
2018-05-11 15:01 UTC, Jérôme Glisse
no flags Details
File: anaconda.log (131.10 KB, text/plain)
2018-05-11 15:02 UTC, Jérôme Glisse
no flags Details
File: dbus.log (6.20 KB, text/plain)
2018-05-11 15:02 UTC, Jérôme Glisse
no flags Details
File: environ (733 bytes, text/plain)
2018-05-11 15:02 UTC, Jérôme Glisse
no flags Details
File: journalctl (809.33 KB, text/plain)
2018-05-11 15:02 UTC, Jérôme Glisse
no flags Details
File: lsblk_output (1.70 KB, text/plain)
2018-05-11 15:02 UTC, Jérôme Glisse
no flags Details
File: nmcli_dev_list (2.36 KB, text/plain)
2018-05-11 15:02 UTC, Jérôme Glisse
no flags Details
File: os_info (623 bytes, text/plain)
2018-05-11 15:02 UTC, Jérôme Glisse
no flags Details
File: program.log (88.75 KB, text/plain)
2018-05-11 15:02 UTC, Jérôme Glisse
no flags Details
File: storage.log (348.88 KB, text/plain)
2018-05-11 15:02 UTC, Jérôme Glisse
no flags Details
File: ifcfg.log (14.66 KB, text/plain)
2018-05-11 15:02 UTC, Jérôme Glisse
no flags Details

Description Jérôme Glisse 2018-05-11 15:01:50 UTC
Version-Release number of selected component:
anaconda-core-28.22.10-1.fc28.x86_64

The following was filed automatically by anaconda:
anaconda 28.22.10 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.6/site-packages/blivet/formats/luks.py", line 217, in _pre_setup
    raise LUKSError("luks device not configured")
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/formats/__init__.py", line 603, in setup
    if not self._pre_setup(**kwargs):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 515, in setup_parents
    _format.setup()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 372, in _pre_setup
    self.setup_parents(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 383, in setup
    if not self._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/deviceaction.py", line 704, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 327, in process
    action.execute(callbacks)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 48, in wrapped_func
    return func(obj, *args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 135, in do_it
    self.devicetree.actions.process(callbacks=callbacks, devices=self.devices)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/storage/osinstall.py", line 1219, in do_it
    super().do_it(callbacks=callbacks)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/storage/osinstall.py", line 2131, in turn_on_filesystems
    storage.do_it(callbacks)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 438, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 361, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 291, in run
    threading.Thread.run(self)
blivet.errors.LUKSError: luks device not configured

Additional info:
addons:         com_redhat_kdump
blivet-gui-utils.log: 
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz root=live:CDLABEL=Fedora-WS-Live-28-1-1 rd.live.image quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.16.3-301.fc28.x86_64
other involved packages: python3-libs-3.6.5-1.fc28.x86_64, python3-blivet-3.0.0-0.6.1.b1.fc28.noarch
product:        Fedora
release:        Fedora release 28 (Twenty Eight)
type:           anaconda
version:        28

Comment 1 Jérôme Glisse 2018-05-11 15:01:59 UTC
Created attachment 1434971 [details]
File: anaconda-tb

Comment 2 Jérôme Glisse 2018-05-11 15:02:01 UTC
Created attachment 1434972 [details]
File: anaconda.log

Comment 3 Jérôme Glisse 2018-05-11 15:02:02 UTC
Created attachment 1434973 [details]
File: dbus.log

Comment 4 Jérôme Glisse 2018-05-11 15:02:03 UTC
Created attachment 1434974 [details]
File: environ

Comment 5 Jérôme Glisse 2018-05-11 15:02:06 UTC
Created attachment 1434975 [details]
File: journalctl

Comment 6 Jérôme Glisse 2018-05-11 15:02:07 UTC
Created attachment 1434976 [details]
File: lsblk_output

Comment 7 Jérôme Glisse 2018-05-11 15:02:08 UTC
Created attachment 1434977 [details]
File: nmcli_dev_list

Comment 8 Jérôme Glisse 2018-05-11 15:02:10 UTC
Created attachment 1434978 [details]
File: os_info

Comment 9 Jérôme Glisse 2018-05-11 15:02:11 UTC
Created attachment 1434979 [details]
File: program.log

Comment 10 Jérôme Glisse 2018-05-11 15:02:13 UTC
Created attachment 1434980 [details]
File: storage.log

Comment 11 Jérôme Glisse 2018-05-11 15:02:15 UTC
Created attachment 1434981 [details]
File: ifcfg.log

Comment 12 Jiri Konecny 2018-05-14 07:53:15 UTC
Based on the traceback this seems like our storage library issue. Changing component.

Comment 13 Vojtech Trefny 2018-09-27 09:19:55 UTC

*** This bug has been marked as a duplicate of bug 1624617 ***


Note You need to log in before you can comment on or make changes to this bug.