Bug 1577287 - session logout does not return to sddm
Summary: session logout does not return to sddm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: sddm
Version: 29
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 15:42 UTC by Peter Gückel
Modified: 2019-09-05 06:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-05 04:46:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Gückel 2018-05-11 15:42:52 UTC
Description of problem:
log in using sddm. log out and the display turns black and stays on vt2. sddm is on vt1. switching with ctrl-alt-f shows this. however, sddm on vt1 shows the blacked-out password and is dead. it does not permit logging back in, shutting down the computer, nothing. the only option is to log in to vt3 or later and shut down or reboot the machine.

Version-Release number of selected component (if applicable):
sddm-0.17.0-2.fc28.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
switching to gdm solves the problem: everything works as expected.

Comment 1 Bert DeKnuydt 2018-11-07 08:42:58 UTC
The very same happens on Fedora 29.

Version:

sddm-0.18.0-1.fc29.x86_64

How reproducible:

Always.

Steps:

1. Setup sddm; default will do
2. Log in, using gnome, or gnome-classic or plasma (others not tested)
3. Log out
4. The log-out half-succeeds.  Some processes remain, the screen
   displays whatever was on there before the logout, but is unresponsive.

Real logout needs a 'loginctl terminate-session' ...

sddm is completely unusable. Back to the ancient kdm ...

Comment 2 Peter Gückel 2018-11-07 17:04:56 UTC
ctrl-alt-delete seems to work to get back to sddm, but this is not acceptible. I have had reliable results 'reverting' to gdm, both with plasma and plasma (wayland).

PS: I changed this to Fedora 29, since I am now on f29 and the problem persists, to the point of sddm being unusable.

Comment 3 Rex Dieter 2018-11-07 17:10:31 UTC
I suspect in at least some of these cases, your user session isn't actually ending (ie, it's a user-session issue, not sddm). 

Options that can mitigate that:
* disable session management (which is the plasma default, unless you changed it).
* set in /etc/systemd/logind.conf :
KillUserProcesses=yes

Comment 4 Peter Gückel 2018-11-08 00:06:23 UTC
(In reply to Rex Dieter from comment #3)
> * disable session management (which is the plasma default, unless you
> changed it).

I have it set to start with an empty session. Is this how it should be? It is what I prefer.

> * set in /etc/systemd/logind.conf :
> KillUserProcesses=yes

Presently (and this is the default file state), it says:

#KillUserProcesses=no

Hmmm. Does that mean that it is set to yes, and I can uncomment to get no? Or does this mean that it is set to no?

Now, should I (a user) really have to change systemd config files to get standard behaviour that always worked previously (simply ending a user session and returning to the login screen, i.e., to the display manager)?

Comment 5 Peter Gückel 2019-09-05 04:46:46 UTC
I am now on fedora 30, so I have no idea if this is still relevant.

Comment 6 Bert DeKnuydt 2019-09-05 06:30:21 UTC
It is still relevant for Fedora 30; changed behavior a bit, as it is not always the case (20% maybe).

Happens with both a Gnome and a Plasma session started from sddm.

Running with a default /etc/systemd/logind.conf;


Note You need to log in before you can comment on or make changes to this bug.