Bug 1577331 - vim-enhanced: ending abbreviations with new line is broken [NEEDINFO]
Summary: vim-enhanced: ending abbreviations with new line is broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 18:02 UTC by Michael S. Tsirkin
Modified: 2018-05-14 14:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-14 14:02:16 UTC
Type: Bug
zdohnal: needinfo? (mst)


Attachments (Terms of Use)

Description Michael S. Tsirkin 2018-05-11 18:02:11 UTC
Description of problem:
I used the following for years:
ab SOB Signed-off-by: Michael S. Tsirkin <mst@redhat.com>

Now one (used to) type in insert mode "SOB<Enter>" and a signed-off-by line
would get added.

Recent update to vim in Fedora 27 broke this.
Now if I type this:

a(to enter insert mode)SOB<Enter>

I get:

igned-off-by: Michael S. Tsirkin <mst@redhat.com>

SOB



Version-Release number of selected component (if applicable):
vim-enhanced-8.0.1763-1.fc27.x86_64

How reproducible:
always

Steps to Reproduce:
1. echo 'ab SOB Signed-off-by: Michael S. Tsirkin <mst@redhat.com>' > ~/.vimrc
2. vim
3. type to enter insert mode: a
4. type to add an empty line: Enter
5. type: SOB
6. type to complete abbreviation: Enter

Actual results:
igned-off-by: Michael S. Tsirkin <mst@redhat.com>
<- cursor here
SOB


Expected results:
<- empty line from original file
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
<- cursor here

Additional info:
if an emoty line is not added in step 4, abbreviation does not
seem to be expanded at all.

Comment 1 Zdenek Dohnal 2018-05-14 14:02:16 UTC
Hi Mike,

thank you for reporting this issue! This problem is fixed in vim-enhanced-8.0.1806.fc27 (it works for me with that version) , would you mind updating vim-enhanced?
Closing this as CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.