Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1577359 - Create Project button shows up on project listing even if you do not have permissions to create a project
Summary: Create Project button shows up on project listing even if you do not have per...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.9.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 19:19 UTC by Chris Kim
Modified: 2018-06-08 02:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The "Create Project" button was incorrectly displayed to users when they had no projects and self provisioning had been disabled on the projects list page of the web console. The action would always fail, so the button should have been hidden. The bug has been fixed, and "Create Project" is now correctly hidden in the console when self-provisioning is disabled.
Clone Of:
Environment:
Last Closed: 2018-06-06 15:46:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1796 0 None None None 2018-06-06 15:47:23 UTC

Description Chris Kim 2018-05-11 19:19:57 UTC
Description of problem:
The Create Project button shows up on the project listing page even when you don't have permissions to create a project.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Remove self-provisioner from system:authenticated and system:authenticated:oauth
2. Set window.OPENSHIFT_CONSTANTS.DISABLE_SERVICE_CATALOG_LANDING_PAGE = true
3. Navigate to web console home page

Actual results:
Create Project button shows up

Expected results:
Create Project button should not show up

Additional info:

Comment 1 Samuel Padgett 2018-05-11 19:32:35 UTC
Fixed by https://github.com/openshift/origin-web-console/pull/2994

> Set window.OPENSHIFT_CONSTANTS.DISABLE_SERVICE_CATALOG_LANDING_PAGE = true

Note this is not a documented / supported setting and will likely disappear in a future release.

Comment 4 openshift-github-bot 2018-05-14 13:02:50 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/695f304daff49dc9acbc73c34750bf048347ee17
Merge pull request #2994 from spadgett/empty-state-projects-btn

Bug 1577359 - Check canCreate in projects empty state message

Comment 10 Yadan Pei 2018-05-31 03:25:02 UTC
1. Remove self-provisioner from system:authenticated:oauth
2. Login and open /console/projects page(Project list page)
No "Create Project" button

Issue fixed on v3.9.30

Comment 12 errata-xmlrpc 2018-06-06 15:46:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1796


Note You need to log in before you can comment on or make changes to this bug.