Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1577406 - libmicrodns needs update to fix crashes already fixed upstream
Summary: libmicrodns needs update to fix crashes already fixed upstream
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libmicrodns
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Nicolas Chauvet (kwizart)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-11 22:04 UTC by Pasi Karkkainen
Modified: 2018-05-15 17:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 17:06:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Pasi Karkkainen 2018-05-11 22:04:51 UTC
Description of problem:

Fedora currently has v0.0.8 of libmicrodns, while upstream is at 0.0.10. Both the upstream 0.0.9 and 0.0.10 releases fix known bugs causing crashes, so Fedora libmicrodns should be updated to the latest version.

For example VLC player (in rpmfusion) uses libmicrodns, and the mentioned bugs crash VLC when trying to select Playback -> Rendeder menu item.

Version-Release number of selected component (if applicable):
microdns-0.0.8-1

How reproducible:
Always.

Steps to Reproduce:
1. Install vlc 3.0.2 from rpmfusion.
2. Start vlc player.
3. Try to choose Playback -> Renderer menu item.

Actual results:
VLC crashes, due to bug(s) in libmicrodns.

Expected results:
VLC (or any other app using libmicrodns) shouldn't crash.

Additional info:
Same libmicrodns bug in Debian, fixed with a libmicrodns update: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=893284

Comment 1 Nicolas Chauvet (kwizart) 2018-05-13 09:47:13 UTC
There is already a new build, but for some reasong they do not appeared in the repo:
https://bodhi.fedoraproject.org/updates/FEDORA-2018-94a142fbd8

Comment 2 Nicolas Chauvet (kwizart) 2018-05-15 16:59:58 UTC
Seems like libmicrodns was published as part of the fedora Everything repo.
If you have updated from a development release, please try

dnf update --refresh

Comment 3 Nicolas Chauvet (kwizart) 2018-05-15 17:01:54 UTC
errata, it's the updates everything, but the same command applies.

Comment 4 Pasi Karkkainen 2018-05-15 17:06:02 UTC
Indeed, "dnf update --refresh libmicrodns" installed version libmicrodns-0.0.10-1. And for example VLC seems to work OK now, without crashing.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.