Red Hat Bugzilla – 1577407 – Glance EP doesn't work. ERROR: Illegal type (com.woorea.openstack.keystone.mode l.Access) to deserialize: prevented for security reasons
Description of problem:
When we need to import template from image from glance external provider we hit error:
Illegal type (com.woorea.openstack.keystone.model.Access) to deserialize: prevented for security reasons
Logs attached
Version-Release number of selected component (if applicable):
rhv-3.6.13-4
Glance version:
openstack-glance-14.0.0-3.el7ost.noarch (rhos-release-11)
First and last host are rhvh (Red Hat Enterprise Virtualization Hypervisor release 7.3 20180510.0.el7ev), second host rhel 7.3
How reproducible:
Steps to Reproduce:
1.Install engine
2.Add external provider
3.Not able to see images
Actual results:
Not able to see images
Expected results:
Be able to import image as a template
We are getting the jackson-mapper-asl jar file from EAP. EAP 6 used by ovirt 3.6 is providing 1.9.9 version of jackson-mapper-asl.
jackson-mapper-asl 1.9.13 is required for openstack-glance-14. Either the jackson-mapper-asl version in EAP 6 needs to be bumped to 1.9.13 or the openstack-glance version should be dropped to 13.
Please test with openstack-glance-13
Hi, we don't have installed any older glance now. So I cannot test it now without installing new glance machine for this purpose. Is there anyone from storage (Raz, Elad) who has available glance version 13 which we can borrow for testing and if it will work, we can deploy older version of glance for purpose of testing 3.6.
Anyway is it somewhere documented which version of glance is supported?
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2018:1720