Bug 1577485 - Fails to create TLS connections
Summary: Fails to create TLS connections
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: syslog-ng
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: mk
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-12 11:10 UTC by Enrico Scholz
Modified: 2018-05-25 15:05 UTC (History)
4 users (show)

Fixed In Version: syslog-ng-3.14.1-5.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-25 15:05:36 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 1916 0 None None None 2018-05-12 11:10:45 UTC

Description Enrico Scholz 2018-05-12 11:10:46 UTC
Description of problem:

When trying to create a TLS protected connection to a remote server, syslog-ng fails with

| Error setting up TLS session context; tls_error='(null):(null):(null)'
| Error initializing message pipeline; plugin name='network', location='root generator common_root:8:2'


This seems to be https://github.com/balabit/syslog-ng/issues/1916 which has been fixed in recent versions.


Version-Release number of selected component (if applicable):

syslog-ng-3.14.1-4.fc28.x86_64


How reproducible:

100%

Comment 1 mk 2018-05-12 13:49:26 UTC
Hi Enrico, and thanks for reporting this issue. The patch provided by upstream applies cleanly. Can you check if this build works for you before I prepare an update?
https://koji.fedoraproject.org/koji/taskinfo?taskID=26920537

Comment 2 Enrico Scholz 2018-05-12 18:37:34 UTC
Thanks for quick reaction; problem seems to be fixed by the new package.

Comment 3 mk 2018-05-12 22:13:04 UTC
Good to hear that it works. I'll submit an update shortly. Since it will have the same release version you may have to manually downgrade back to 3.14.1-4.fc28 once it's available if you want dnf to update you to the official package.

Comment 4 Fedora Update System 2018-05-12 22:13:50 UTC
syslog-ng-3.14.1-5.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5c87acb9af

Comment 5 Fedora Update System 2018-05-13 22:22:27 UTC
syslog-ng-3.14.1-5.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5c87acb9af

Comment 6 Fedora Update System 2018-05-25 15:05:36 UTC
syslog-ng-3.14.1-5.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.