Bug 1577518 - [abrt] dnssec-trigger: check_call(): subprocess.py:291:check_call:subprocess.CalledProcessError: Command '['unbound-control', 'flush_zone', '.']' returned non-zero exit status 1.
Summary: [abrt] dnssec-trigger: check_call(): subprocess.py:291:check_call:subprocess....
Keywords:
Status: CLOSED DUPLICATE of bug 1547476
Alias: None
Product: Fedora
Classification: Fedora
Component: dnssec-trigger
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a7f47c177720888e355566968b3...
: 1489171 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-12 16:55 UTC by Christian Stadelmann
Modified: 2018-12-06 09:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-06 09:13:02 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.29 KB, text/plain)
2018-05-12 16:55 UTC, Christian Stadelmann
no flags Details
File: cpuinfo (1.38 KB, text/plain)
2018-05-12 16:55 UTC, Christian Stadelmann
no flags Details
File: namespaces (129 bytes, text/plain)
2018-05-12 16:55 UTC, Christian Stadelmann
no flags Details

Description Christian Stadelmann 2018-05-12 16:55:22 UTC
Version-Release number of selected component:
dnssec-trigger-0.15-4.fc28

Additional info:
reporter:       libreport-2.9.5
cmdline:        /usr/bin/python3 -sE /usr/libexec/dnssec-trigger-script --update
crash_function: check_call
exception_type: subprocess.CalledProcessError
executable:     /usr/libexec/dnssec-trigger-script
interpreter:    python3-3.6.5-1.fc28.x86_64
kernel:         4.16.7-300.fc28.x86_64
runlevel:       N 5
type:           Python3

Truncated backtrace:
subprocess.py:291:check_call:subprocess.CalledProcessError: Command '['unbound-control', 'flush_zone', '.']' returned non-zero exit status 1.

Traceback (most recent call last):
  File "/usr/libexec/dnssec-trigger-script", line 748, in <module>
    main()
  File "/usr/libexec/dnssec-trigger-script", line 735, in main
    Application(sys.argv).run()
  File "/usr/libexec/dnssec-trigger-script", line 470, in run
    self.method()
  File "/usr/libexec/dnssec-trigger-script", line 632, in run_update
    self.run_update_global_forwarders()
  File "/usr/libexec/dnssec-trigger-script", line 655, in run_update_global_forwarders
    UnboundZoneConfig._control([config.flush_command, "."])
  File "/usr/libexec/dnssec-trigger-script", line 306, in _control
    subprocess.check_call(["unbound-control"] + args, stdout=DEVNULL, stderr=DEVNULL)
  File "/usr/lib64/python3.6/subprocess.py", line 291, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['unbound-control', 'flush_zone', '.']' returned non-zero exit status 1.

Local variables in innermost frame:
cmd: ['unbound-control', 'flush_zone', '.']
retcode: 1
kwargs: {'stdout': <_io.BufferedWriter name='/dev/null'>, 'stderr': <_io.BufferedWriter name='/dev/null'>}
popenargs: (['unbound-control', 'flush_zone', '.'],)

Potential duplicate: bug 1489169

Comment 1 Christian Stadelmann 2018-05-12 16:55:30 UTC
Created attachment 1435461 [details]
File: backtrace

Comment 2 Christian Stadelmann 2018-05-12 16:55:31 UTC
Created attachment 1435462 [details]
File: cpuinfo

Comment 3 Christian Stadelmann 2018-05-12 16:55:33 UTC
Created attachment 1435463 [details]
File: namespaces

Comment 4 Christian Stadelmann 2018-06-13 05:45:14 UTC
*** Bug 1489171 has been marked as a duplicate of this bug. ***

Comment 5 Dominik 'Rathann' Mierzejewski 2018-07-10 10:08:48 UTC
Similar problem has been detected:

Resumed from suspend and connected to a Wi-Fi network.

reporter:       libreport-2.9.5
cmdline:        /usr/bin/python3 -sE /usr/libexec/dnssec-trigger-script --update
crash_function: check_call
exception_type: subprocess.CalledProcessError
executable:     /usr/libexec/dnssec-trigger-script
interpreter:    python3-3.6.5-1.fc28.x86_64
kernel:         4.17.3-200.fc28.x86_64
package:        dnssec-trigger-0.15-5.fc28
reason:         subprocess.py:291:check_call:subprocess.CalledProcessError: Command '['unbound-control', 'flush_zone', '.']' returned non-zero exit status 1.
runlevel:       N 5
type:           Python3
uid:            0

Comment 6 Tomáš Hozza 2018-12-06 09:13:02 UTC

*** This bug has been marked as a duplicate of bug 1547476 ***


Note You need to log in before you can comment on or make changes to this bug.