Bug 1577537 - [OSP13] inconsistent tags for overcloud images in registry.access.redhat.com/rhosp13-beta
Summary: [OSP13] inconsistent tags for overcloud images in registry.access.redhat.com/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-containers
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Jon Schlueter
QA Contact: Omri Hochman
Andrew Burden
URL:
Whiteboard:
: 1594110 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-12 20:39 UTC by Michael Henkel
Modified: 2018-07-09 11:22 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
Fixes OSP 13 Beta issue where some container images were not available.
Clone Of:
Environment:
Last Closed: 2018-06-28 08:00:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2085 0 None None None 2018-06-28 08:01:13 UTC

Description Michael Henkel 2018-05-12 20:39:17 UTC
Description of problem:

Some images are available with tag 13.0, some with latest and some are missing (openstack-swift-container):


(undercloud) [stack@osp13 ~]$ tag=`openstack overcloud container image tag discover \
>   --image registry.access.redhat.com/rhosp13-beta/openstack-base:latest \
>   --tag-from-label version`
(undercloud) [stack@osp13 ~]$ echo $tag
13.0
(undercloud) [stack@osp13 ~]$ docker pull registry.access.redhat.com/rhosp13-beta/openstack-swift-container:13.0
Trying to pull repository registry.access.redhat.com/rhosp13-beta/openstack-swift-container ...
error parsing HTTP 404 response body: invalid character 'F' looking for beginning of value: "File not found.\""

docker pull registry.access.redhat.com/rhosp13-beta/openstack-haproxy:13.0
Trying to pull repository registry.access.redhat.com/rhosp13-beta/openstack-haproxy ...
error parsing HTTP 404 response body: invalid character 'F' looking for beginning of value: "File not found.\""

(undercloud) [stack@osp13 ~]$ docker pull registry.access.redhat.com/rhosp13-beta/openstack-haproxy:latest
Trying to pull repository registry.access.redhat.com/rhosp13-beta/openstack-haproxy ...
latest: Pulling from registry.access.redhat.com/rhosp13-beta/openstack-haproxy
Digest: sha256:e4f20151ce35306701be80fd9f8648364d5f83c27b97c5a9c5438ec01af20d24
Status: Image is up to date for registry.access.redhat.com/rhosp13-beta/openstack-haproxy:latest

Version-Release number of selected component (if applicable):

OSP13

How reproducible:

see above

Steps to Reproduce:
1.
2.
3.

Actual results:

some images are not pulled

Expected results:

all images are pulled

Additional info:

Comment 1 Jon Schlueter 2018-05-15 13:37:24 UTC
Issue identified with content push for containers for Beta.  Correction being attempted currently.

Comment 2 Jon Schlueter 2018-05-15 14:18:31 UTC
# docker pull registry.access.redhat.com/rhosp13-beta/openstack-swift-container:13.0
Trying to pull repository registry.access.redhat.com/rhosp13-beta/openstack-swift-container ... 
13.0: Pulling from registry.access.redhat.com/rhosp13-beta/openstack-swift-container
Digest: sha256:7d9c4b996c5d1ecb788ab403342085696d9b3da88f4fc02d94cb697e5b74dfc3


Is now up and working.  Also found 6 others that we are investigating


Trying to pull repository registry.access.redhat.com/rhosp13-beta/openstack-barbican-keystone-listener ... 
unknown: Not Found
Trying to pull repository registry.access.redhat.com/rhosp13-beta/openstack-barbician-api ... 
unknown: Not Found
Trying to pull repository registry.access.redhat.com/rhosp13-beta/openstack-fluentd ... 
error parsing HTTP 404 response body: invalid character 'F' looking for beginning of value: "File not found.\""
Trying to pull repository registry.access.redhat.com/rhosp13-beta/openstack-zaqar ... 
error parsing HTTP 404 response body: invalid character 'F' looking for beginning of value: "File not found.\""
Trying to pull repository registry.access.redhat.com/rhosp13-beta/openstack-nova-scheduler ... 
error parsing HTTP 404 response body: invalid character 'F' looking for beginning of value: "File not found.\""
Trying to pull repository registry.access.redhat.com/rhosp13-beta/openstack-aodh-base ... 
error parsing HTTP 404 response body: invalid character 'F' looking for beginning of value: "File not found.\""

Comment 4 Jon Schlueter 2018-05-23 15:30:04 UTC
Verified all expected rhosp13-beta containers are up on redhat registry now.

Comment 6 Alex Schultz 2018-05-23 15:32:46 UTC
*** Bug 1579483 has been marked as a duplicate of this bug. ***

Comment 10 David Casier 2018-06-22 07:22:24 UTC
*** Bug 1594110 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2018-06-28 08:00:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2085


Note You need to log in before you can comment on or make changes to this bug.