Bug 157754 - Mail failure after upgrade
Mail failure after upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2005-05-14 11:35 EDT by David Woodhouse
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 18:37:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (13.58 KB, text/plain)
2005-05-19 02:52 EDT, David Woodhouse
no flags Details
anaconda.syslog (26.74 KB, text/plain)
2005-05-19 02:52 EDT, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2005-05-14 11:35:36 EDT
Sendmail was installed after an upgrade from FC3 to FC4. Exim was no longer
working, and doesn't get fixed by 'yum update exim'. 

The removal of all 1.5MiB of the Exim package from FC4 was excused on the basis
that it's now in Extras, and that 'yum update exim' would suffice to fix the
breakage after upgrading. That isn't the case though; this needs to be fixed, or
the unnecessary removal of Exim needs to be reconsidered.

peach /home/dwmw2 $ telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 peach.infradead.org ESMTP Sendmail 8.13.4/8.13.4; Sat, 14 May 2005 16:22:28
+0100
^]close

telnet> close
Connection closed.
peach /home/dwmw2 $ su
Password:
peach /home/dwmw2 # rpm -e sendmail
error: Failed dependencies:
        sendmail = 8.13.4-2 is needed by (installed) sendmail-cf-8.13.4-2.ppc
        sendmail = 8.13.4-2 is needed by (installed) sendmail-devel-8.13.4-2.ppc
       sendmail = 8.13.4-2 is needed by (installed) sendmail-doc-8.13.4-2.ppc
peach /home/dwmw2 # rpm -e sendmail sendmail-cf sendmail-devel sendmail-doc
warning: /var/log/mail/statistics saved as /var/log/mail/statistics.rpmsave
peach /home/dwmw2 # /sbin/service exim restart
Shutting down exim:                                        [FAILED]
Starting exim: /usr/sbin/exim: error while loading shared libraries:
libssl.so.4: cannot open shared object file: No such file or directory
                                                           [FAILED]
peach /home/dwmw2 # yum update exim
Repository updates-released already added, not adding again
Setting up Update Process
Setting up repositories
extras-ppc                100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
updates-released          100% |=========================|  951 B    00:00
extras-noarch             100% |=========================|  951 B    00:00
fc3-updates-released      100% |=========================|  951 B    00:00
Reading repository metadata in from local files
extras-ppc: ################################################## 687/687
Added 687 new packages, deleted 0 old in 11.05 seconds
base      : ################################################## 1865/1865
Added 1865 new packages, deleted 0 old in 38.89 seconds
updates-re: ################################################## 31/31
Added 31 new packages, deleted 0 old in 0.73 seconds
primary.xml.gz            100% |=========================| 295 kB    00:05
extras-noa: ################################################## 870/870
Added 870 new packages, deleted 0 old in 13.47 seconds
fc3-update: ################################################## 1300/1300
Added 1300 new packages, deleted 0 old in 40.11 seconds
Could not find update match for exim
No Packages marked for Update/Obsoletion
peach /home/dwmw2 #
Comment 1 Bill Nottingham 2005-05-16 14:28:15 EDT
You've got a improper repository configuration; it's pointing at the wrong trees
(base, updates-released) as opposed to fedora-core-development and
extras-development.
Comment 2 David Woodhouse 2005-05-16 14:44:27 EDT
Is that what caused sendmail to be installed?
And shouldn't something have fixed it for me on upgrade?
Comment 3 Bill Nottingham 2005-05-16 15:05:28 EDT
It was probably installed to satisfy a dependency.

As for getting the proper repos on upgrade, that will happen if you upgrade to a
proper fedora-release; the one in rawhide is probably not it (I don't think it
gets pulled in on upgrades.)
Comment 4 David Woodhouse 2005-05-16 17:41:18 EDT
I was able to remove sendmail without having to use --nodeps. There shouldn't
have been anything requiring it. This sounds like an installer bug.

Regarding the presence of the 'proper repos' -- if FC4test doesn't include a
fedora-release which pulls in Extras, how is the supposed upgrade path from FC3
to FC4+FE4 going to get tested? At this stage we really can't claim that Fedora
Extras is ready to roll, can we? And we have to revisit decisions which were
made on the basis that it _would_ be ready.
Comment 5 David Woodhouse 2005-05-16 17:44:20 EDT
Seriously -- removing Exim was crack-inspired decision in the first place,
especially as we're still leaving duplicate MTA functionality in FC4. But it was
justified on the basis that Extras would be ready. Extras _isn't_ ready -- what
are we going to do about it? Closing this NOTABUG isn't helpful. Dividing it up
into an installer bug (for installing sendmail) and a fedora-release bug (for
not including Extras) might at least help to move us forward. 
Comment 6 Bill Nottingham 2005-05-16 17:46:43 EDT
FC4 test *does* have a valid repo definition.

FC4 devel tree (aka rawhide) may not, in that 'yum upgrade' from FC3 to rawhide
may not obsolete fedora-release with rawhide-release.

What version of fedora-release do you have installed?
Comment 7 David Woodhouse 2005-05-16 18:27:05 EDT
fedora-release-3-rawhide. I've confirmed that updating to fedora-release-3.92-1
does give me Extras support in yum, although not AFAICT up2date. Thanks.

There remains the fact that the installer not only installed sendmail, but
started it running by default.
Comment 8 Bill Nottingham 2005-05-16 21:38:08 EDT
Well, sendmail defaults to:

# chkconfig: 2345 80 30

so, it will default to starting on any initial install of it.

Not sure why it would decide to install it on upgrade, though.
Comment 9 Jeremy Katz 2005-05-18 21:35:42 EDT
Can you provide /var/log/anaconda*
Comment 10 David Woodhouse 2005-05-19 02:52:10 EDT
Created attachment 114552 [details]
anaconda.log
Comment 11 David Woodhouse 2005-05-19 02:52:45 EDT
Created attachment 114553 [details]
anaconda.syslog
Comment 12 Jeremy Katz 2005-05-23 13:07:36 EDT
It looks like you had something installed which required sendmail (or the new
version at least did) and that's why sendmail got pulled in.  

openssl097a should have gotten pulled in, though, and it's not.  Reproduced
locally and sticking on the list to fix.
Comment 13 David Woodhouse 2005-05-23 13:16:38 EDT
(In reply to comment #12)
> It looks like you had something installed which required sendmail (or the new
> version at least did) and that's why sendmail got pulled in.  

AFAIK there was nothing installed previously which required sendmail. I haven't
had to 'rpm -e --nodeps sendmail' for a long time. 

There was certainly nothing installed _after_ the upgrade which required
sendmail. I was able to remove it without dependency problems.

I reproduced this again yesterday. 

Comment 14 Jeremy Katz 2005-05-23 16:38:42 EDT
Fixed in CVS such that openssl097a will get pulled in correctly on an upgrade.  

sendmail-cf previously didn't depend on sendmail, but now does and thus on your
upgrade, you get sendmail added to satisfy that dep (correctly).
Comment 15 David Woodhouse 2005-05-23 16:46:28 EDT
Hm, I'm surprised sendmail-cf was installed on both machines, but I can't swear
it wasn't. I'll double-check before I upgrade the next machine.
Comment 16 David Woodhouse 2005-05-25 05:20:30 EDT
Confirmed that it doesn't happen on two machines which definitely didn't have
sendmail-cf installed before the upgrade.

Given that sendmail runs by default after you install it though, this is
probably worth fixing in the installer. If sendmail-cf is installed but not
sendmail, it should perhaps remove sendmail-cf instead of installing sendmail.

On a similar note, evince isn't getting installed even though I had xpdf
installed before the upgrade. 
Comment 17 Rahul Sundaram 2005-08-23 20:08:39 EDT
David Woodhouse,

AIUI, The current bug/RFE report is to remove sendmail-cf during the upgrade if
sendmail is not installed. So wouldnt it make sense for the sendmail-cf package
to depend on sendmail itself. So you can do a yum remove sendmail and get rid of
them both. Is there any reason for someone to install sendmail-cf and not
sendmail? .  If this idea seems reasonable,  this report should be filed against
sendmail instead. 

Kindly file a new report for the evince issue. thanks
Comment 18 Bug Zapper 2008-04-03 12:10:15 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Note You need to log in before you can comment on or make changes to this bug.