Bug 1577542 - Cannot uninstall libvirt-daemon
Summary: Cannot uninstall libvirt-daemon
Keywords:
Status: CLOSED DUPLICATE of bug 1558648
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 28
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-12 21:54 UTC by Randy Barlow
Modified: 2018-05-14 06:06 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-14 06:06:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Randy Barlow 2018-05-12 21:54:35 UTC
Description of problem:
[rbarlow@ohm ~]$ sudo dnf distro-sync
Last metadata expiration check: 4:33:55 ago on Sat 12 May 2018 01:16:53 PM EDT.
Dependencies resolved.
======================================================================================================================
 Package                         Arch                    Version                       Repository                Size
======================================================================================================================
Removing dependent packages:
 libvirt-daemon                  x86_64                  4.1.0-1.fc28                  @fedora                  2.8 M

Transaction Summary
======================================================================================================================
Remove  1 Package

Freed space: 2.8 M
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                              1/1 
  Running scriptlet: libvirt-daemon-4.1.0-1.fc28.x86_64                                                           1/1 
/var/tmp/rpm-tmp.mb9Qc7: line 6: virtlogd.socket: command not found
error: %preun(libvirt-daemon-4.1.0-1.fc28.x86_64) scriptlet failed, exit status 127
Error in PREUN scriptlet in rpm package libvirt-daemon
Error in PREUN scriptlet in rpm package libvirt-daemon
libvirt-daemon-4.1.0-1.fc28.x86_64 was supposed to be removed but is not!
  Verifying        : libvirt-daemon-4.1.0-1.fc28.x86_64                                                           1/1 

Failed:
  libvirt-daemon.x86_64 4.1.0-1.fc28                                                                                  

Error: Transaction failed

Comment 1 Ján Tomko 2018-05-14 06:06:10 UTC
Per https://bugzilla.redhat.com/show_bug.cgi?id=1558648#c5
the package with the broken script needs to be removed manually:
rpm -e --noscripts libvirt-daemon-4.1.0-1.fc28

*** This bug has been marked as a duplicate of bug 1558648 ***


Note You need to log in before you can comment on or make changes to this bug.