Bug 1577549 - Can't system-upgrade from releasever 28 to rawhide [NEEDINFO]
Summary: Can't system-upgrade from releasever 28 to rawhide
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-13 00:00 UTC by Matt Daveson
Modified: 2019-03-04 12:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-04 12:59:49 UTC
Type: Bug
jmracek: needinfo? (reportbug)


Attachments (Terms of Use)

Description Matt Daveson 2018-05-13 00:00:35 UTC
[root@localhost ~]# sudo dnf system-upgrade download --refresh --releasever=rawhide
Failed to set locale, defaulting to C
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Failed to synchronize cache for repo 'rpmfusion-free-updates', disabling.
Failed to synchronize cache for repo 'rpmfusion-nonfree-nvidia-driver', disabling.
Failed to synchronize cache for repo 'rpmfusion-nonfree-updates', disabling.
Last metadata expiration check: 0:00:00 ago on Sun May 13 00:24:37 2018.
Error: 
 Problem 1: xorg-x11-drv-nvidia-libs-3:390.48-2.fc28.i686 has inferior architecture
  - xorg-x11-drv-nvidia-libs-3:390.48-2.fc28.x86_64 does not belong to a distupgrade repository
  - problem with installed package xorg-x11-drv-nvidia-libs-3:390.48-2.fc28.i686
 Problem 2: problem with installed package libglvnd-glx-1:1.0.1-0.5.20180327git5baa1e5.fc28.i686
  - package xorg-x11-drv-nvidia-libs-3:396.24-2.fc29.x86_64 requires (xorg-x11-drv-nvidia-libs(x86-32) = 3:396.24-2.fc29 if libGL(x86-32)), but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:396.24-2.fc29.x86_64 requires libnvidia-glcore.so.396.24()(64bit), but none of the providers can be installed
  - package kmod-nvidia-4.16.7-300.fc28.x86_64-3:390.48-1.fc28.x86_64 requires nvidia-kmod-common >= 3:390.48, but none of the providers can be installed
  - xorg-x11-drv-nvidia-3:390.48-2.fc28.x86_64 does not belong to a distupgrade repository
  - libglvnd-glx-1:1.0.1-0.5.20180327git5baa1e5.fc28.i686 does not belong to a distupgrade repository
  - problem with installed package kmod-nvidia-4.16.7-300.fc28.x86_64-3:390.48-1.fc28.x86_64
 Problem 3: problem with installed package mesa-libGL-18.0.2-1.fc28.i686
  - package mesa-libGL-18.1.0-0.2.rc3.fc29.i686 requires libglvnd-glx(x86-32), but none of the providers can be installed
  - package xorg-x11-drv-nvidia-libs-3:396.24-2.fc29.x86_64 requires (xorg-x11-drv-nvidia-libs(x86-32) = 3:396.24-2.fc29 if libGL(x86-32)), but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:396.24-2.fc29.x86_64 requires libnvidia-glcore.so.396.24()(64bit), but none of the providers can be installed
  - package akmod-nvidia-3:396.24-1.fc29.x86_64 requires nvidia-kmod-common >= 3:396.24, but none of the providers can be installed
  - package libglvnd-glx-1:1.0.1-0.5.20180327git5baa1e5.fc28.i686 requires libglvnd(x86-32) = 1:1.0.1-0.5.20180327git5baa1e5.fc28, but none of the providers can be installed
  - problem with installed package akmod-nvidia-3:390.48-1.fc28.x86_64
  - mesa-libGL-18.0.2-1.fc28.i686 does not belong to a distupgrade repository
  - libglvnd-1:1.0.1-0.5.20180327git5baa1e5.fc28.i686 does not belong to a distupgrade repository
  - akmod-nvidia-3:390.48-1.fc28.x86_64 does not belong to a distupgrade repository

Comment 1 Jaroslav Mracek 2018-05-24 07:30:10 UTC
Please can you try same operation with --allowerasing -v and provide a result? Then try to install the the removed files into empty installroot: "sudo dnf install <pkg> --releasever rawhide --installroot /<installroot>"

Please additionaly check that there are no exclude, include in /etc/dnf/dnf.conf or /etc/yum.repos.d/*.repo.

Additionally a versionlock plugin could also disable some packages.

Comment 2 Jaroslav Mracek 2019-03-04 12:59:49 UTC
I believe that the issue is fixed (problem with dependency in rawhide). Please if you think that it is still relevant, please don't hesitate to reopen the bug report.


Note You need to log in before you can comment on or make changes to this bug.