Bug 1577577 - kube-proxy error
Summary: kube-proxy error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kubernetes
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-13 07:12 UTC by Matthew McGillis
Modified: 2018-05-23 00:36 UTC (History)
9 users (show)

Fixed In Version: kubernetes-1.10.1-0.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-16 13:06:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Matthew McGillis 2018-05-13 07:12:36 UTC
Description of problem:
kube-proxy constantly generating error:
May 12 23:20:58 localhost kube-proxy[2470]: E0512 23:20:58.113414    2470 proxier.go:1667] Failed to execute iptables-restore: exit status 1 (iptables-restore: invalid option -- '5'
May 12 23:20:58 localhost kube-proxy[2470]: Try `iptables-restore -h' for more information.
May 12 23:20:58 localhost kube-proxy[2470]: )
May 12 23:21:28 localhost kube-proxy[2470]: E0512 23:21:28.128008    2470 proxier.go:1667] Failed to execute iptables-restore: exit status 1 (iptables-restore: invalid option -- '5'
May 12 23:21:28 localhost kube-proxy[2470]: Try `iptables-restore -h' for more information.
May 12 23:21:28 localhost kube-proxy[2470]: )


Version-Release number of selected component (if applicable):
# rpm -q -a | grep kube
kubernetes-master-1.9.3-1.fc28.x86_64
kubernetes-client-1.9.3-1.fc28.x86_64
kubernetes-1.9.3-1.fc28.x86_64
kubernetes-node-1.9.3-1.fc28.x86_64
# uname -a
Linux dhcp053.jenika.com 4.16.3-301.fc28.x86_64 #1 SMP Mon Apr 23 21:59:58 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
Basic fedora 28 server install then install kuberneetes and monitor logs.

Steps to Reproduce:
1. dnf -y install kubernetes etcd flannel
2. systemctl mask firewalld
3. systemctl stop firewalld
4. systemctl start etcd
5. systemctl start kube-apiserver
6. systemctl start kube-controller-manager
7. systemctl start kube-scheduler
8. vi /root/flannel-config.json
{
    "Network": "18.16.0.0/16",
    "SubnetLen": 24,
    "Backend": {
        "Type": "vxlan",
        "VNI": 1
     }
}
9. etcdctl set /atomic.io/network/config </root/flannel-config.json
10. systemctl start kube-proxy
11. tail -f /var/log/messages

Actual results:
Get the above errors in log.

Expected results:
Errors not generated in log.

Additional info:

I believe because of the above I'm unable to get proper flannel networking working in a cluster: single master, 2 nodes.

This may or may not help but it seems to talk about the same issue:
https://github.com/kubernetes/kubernetes/issues/58956

Comment 1 Fedora Update System 2018-05-16 10:52:21 UTC
kubernetes-1.10.1-0.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9b965c4eed

Comment 2 Jan Chaloupka 2018-05-16 10:53:14 UTC
https://github.com/kubernetes/kubernetes/pull/61734 is already part of v1.10.1. Can you test the latest build and verify if it works for you?

Comment 3 Fedora Update System 2018-05-16 13:06:08 UTC
kubernetes-1.10.1-0.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 4 Matthew McGillis 2018-05-23 00:36:56 UTC
Looks good to me.


Note You need to log in before you can comment on or make changes to this bug.