Bug 1577623 - boinc-client in F28 cannot utilize OpenCL on multiple nvidia gpus.
Summary: boinc-client in F28 cannot utilize OpenCL on multiple nvidia gpus.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: boinc-client
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Laurence Field
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-13 14:48 UTC by tetsuji-rai
Modified: 2018-11-26 09:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-26 09:15:47 UTC
Type: Bug


Attachments (Terms of Use)

Description tetsuji-rai 2018-05-13 14:48:19 UTC
Description of problem:

BOINC originally has ability to use multiple GPUs (including Intel/nvidia) for OpenCL calculation.  However, F28 can utilize only one GPU at once for OpenCL.


Version-Release number of selected component (if applicable):

At least 7.8.x, 7.9.x, 7.10.x 7.11.0; ie. all the currently available versions.


How reproducible:

Install boinc-client on F28 computer with 2 or more nvidia/intel GPUs.  Use boinc-manager to attach to OpenCL project(s).  boinc requires <use_all_gpus>1</use_all_gpus> configuration in /var/lib/boinc/cc_config.xml to utilize multiple GPUs, however F28, this doesn't work.  Only one GPU is used for OpenCL anyway.

OTOH F27 works fine; multiple GPUs can be used in F27.   F28 cannot do it.

Comment 1 tetsuji-rai 2018-05-14 01:03:11 UTC
Now I'm running F27, and after 9 or 10 hours of testing, boinc-client began to ignore multiple GPUs.  It only uses one GPU again.  I checked it with version 7.9 (coming with F27 package) and 7.11 (built from git).

Comment 2 tetsuji-rai 2018-05-14 01:20:21 UTC
The only thinkable remedy was to clear /var/lib/boinc directory and begin setting up, and it worked.   It's very uneasy.

It may be due to BOINC project, not to Fedora project.

Comment 3 tetsuji-rai 2018-05-31 21:57:23 UTC
Sorry, I forgot to write solution.  It happens when the preference as to how many tasks should be stored is set to more than one day.   If it's set to 1 day or less, this problem doesn't happen.

Please close this issue.


Note You need to log in before you can comment on or make changes to this bug.