Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1577658 - Use CentOS 7.5 $contentdir in delorean-deps.repo
Summary: Use CentOS 7.5 $contentdir in delorean-deps.repo
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: RDO
Classification: Community
Component: Infrastructure
Version: trunk
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: trunk
Assignee: Javier Peña
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-13 19:29 UTC by Marcin Juszkiewicz
Modified: 2018-06-05 12:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-05 12:39:29 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
RDO 13763 0 None None None 2018-05-14 08:15:26 UTC

Description Marcin Juszkiewicz 2018-05-13 19:29:48 UTC
Description of problem:

delorean-deps.repo file points into two Delorean repos and to CentOS 'kvm-common' one. The problem is that the last one points to /centos/ so works only on x86-64.

CentOS 7.5 has 'kvm-common' synced for alternate archs so it can be used. It also introduced new YUM variable for it: $contentdir.

Changed repo definition:

[rdo-qemu-ev]
name=RDO CentOS-$releasever - QEMU EV
baseurl=http://mirror.centos.org/$contentdir/7/virt/$basearch/kvm-common/
gpgcheck=0
enabled=1
skip_if_unavailable=1

This way I can simplify code of Kolla project to just use it directly and not have to answer users asking "why I have 404 each time I do package installation".

Comment 1 Javier Peña 2018-05-14 08:15:27 UTC
This makes sense. I have created https://review.rdoproject.org/r/13763 with the required changes to puppet-dlrn.

Comment 2 Marcin Juszkiewicz 2018-06-05 12:21:56 UTC
Change got merged. Any idea when https://trunk.rdoproject.org/centos7/delorean-deps.repo will start using it?

Comment 3 Javier Peña 2018-06-05 12:39:29 UTC
I've just run the Puppet manifests, so it's in place. Closing.


Note You need to log in before you can comment on or make changes to this bug.