Bug 1577668 - Regressions/smoke/other tests failing in build (due to new deprecated warnings)
Summary: Regressions/smoke/other tests failing in build (due to new deprecated warnings)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-13 21:18 UTC by Shyamsundar
Modified: 2018-09-17 07:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-17 07:19:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2018-05-13 21:18:37 UTC
Description of problem:
A lot of smoke/regression hosts are failing builds upstream. This is due to the following warning in the build,

CC       bd-helper.lo
In file included from /home/jenkins/root/workspace/smoke/xlators/storage/bd/src/bd.c:20:0:
/usr/include/lvm2app.h:22:2: error: #warning "liblvm2app is deprecated, use D-Bus API instead." [-Werror=cpp]
#warning "liblvm2app is deprecated, use D-Bus API instead."
   ^
In file included from /home/jenkins/root/workspace/smoke/xlators/storage/bd/src/bd-helper.c:1:0:
/usr/include/lvm2app.h:22:2: error: #warning "liblvm2app is deprecated, use D-Bus API instead." [-Werror=cpp]
#warning "liblvm2app is deprecated, use D-Bus API instead."
   ^
cc1: all warnings being treated as errors

Version-Release number of selected component (if applicable): ALL


How reproducible: Pretty much always now, depends in machine roulette!

The problem is fairly new, started Friday (11th May, 2018) morning, in an assumption to check if it was one or two machines I took a few offline, but the problem is only creeping to other machines.

My suspicion is that there is a recent package update causing this. Although the problem is real (I can see the same in my Fedora 27 machine (for quite some time now)) it is causing a lot of failures in tests.

Starting with infra to see if there is a quick fix around this failure, if not we need to pick up the work in bd xlator to fox the same.

Comment 2 Nigel Babu 2018-05-14 02:34:10 UTC
I have a temporary fix here: https://github.com/gluster/glusterfs-patch-acceptance-tests/pull/130

However, we should open a bug to fix the bd xlator to work with D-Bus API or drop the BD xlator. Given that the xlator is orphaned, I'm learning towards drop. I don't see a bug component for it, so for now, I'm leaving this bug in infra.


Note You need to log in before you can comment on or make changes to this bug.