Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1577675 - file /usr/include/sasl/md5global.h conflicts between attempted installs of cyrus-sasl-devel-2.1.27-0.1rc7.fc28.i686 and cyrus-sasl-devel-2.1.27-0.1rc7.fc28.x86_64
Summary: file /usr/include/sasl/md5global.h conflicts between attempted installs of cy...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-sasl
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-13 22:19 UTC by Villy Kruse
Modified: 2018-05-22 15:06 UTC (History)
4 users (show)

Fixed In Version: cyrus-sasl-2.1.27-0.2rc7.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-22 15:06:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Villy Kruse 2018-05-13 22:19:28 UTC
Description of problem:

Unable to instal  cyrus-sasl-devel-2.1.27-0.1rc7.fc28.i686 and cyrus-sasl-devel-2.1.27-0.1rc7.fc28.x86_64 at the same time.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1.
    dnf install cyrus-sasl-devel.x86_64 cyrus-sasl-devel.i686

Actual results:

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/include/sasl/md5global.h conflicts between attempted installs of cyrus-sasl-devel-2.1.27-0.1rc7.fc28.i686 and cyrus-sasl-devel-2.1.27-0.1rc7.fc28.x86_64


Expected results:

Normal installation of noth 32bit and 64bit devel package.

Additional info:

Someone on ask.fedoraproject.org could not upgrad to fc28 from fc27 because of this issue.

Comment 1 Jakub Jelen 2018-05-17 12:11:53 UTC
Thank you for the bug report.

The md5global.h file is generated during the build and the 64 bit type is not available on i686 architecture. Fortunately, it is not needed anywhere in the codebase so I restored the old patch that is using the predefined header file and I will talk with upstream about options how to get rid of this for good.

The updates for Fedora 28 are on the way.

Comment 2 Fedora Update System 2018-05-17 12:49:20 UTC
cyrus-sasl-2.1.27-0.2rc7.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7977b3fa1e

Comment 3 Fedora Update System 2018-05-19 04:19:55 UTC
cyrus-sasl-2.1.27-0.2rc7.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7977b3fa1e

Comment 4 Fedora Update System 2018-05-22 15:06:55 UTC
cyrus-sasl-2.1.27-0.2rc7.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.