Bug 1577707 - Dependency "hostname.x86_64" is only available in CentOS 7
Summary: Dependency "hostname.x86_64" is only available in CentOS 7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: etckeeper
Version: el6
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1578892 1580065 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-14 03:00 UTC by David Kaufmann
Modified: 2018-05-19 22:57 UTC (History)
10 users (show)

Fixed In Version: etckeeper-1.18.7-3.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-19 22:57:39 UTC
Type: Bug


Attachments (Terms of Use)

Description David Kaufmann 2018-05-14 03:00:23 UTC
Description of problem:
Update on CentOS 6 is not possible, as the "hostname" command is provided by "net-tools.x86_64" on CentOS 6 but by "hostname.x86_64" on CentOS 7.

Version-Release number of selected component (if applicable):
etckeeper-1.18.7-2.el6.noarch

How reproducible:
yum update

Steps to Reproduce:
1. yum update

Actual results:
Error: Package: etckeeper-1.18.7-2.el6.noarch (epel)
           Requires: hostname

Expected results:
Update succeeds

Thanks,
David

Comment 1 Shane 2018-05-14 05:21:36 UTC
Same. Presumably broken by: https://bugzilla.redhat.com/show_bug.cgi?id=1418790

Comment 2 Fedora Update System 2018-05-14 12:47:53 UTC
etckeeper-1.18.7-3.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-45ab07ba94

Comment 3 Fedora Update System 2018-05-14 19:34:06 UTC
etckeeper-1.18.7-3.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-45ab07ba94

Comment 4 Thomas Moschny 2018-05-17 06:57:37 UTC
*** Bug 1578892 has been marked as a duplicate of this bug. ***

Comment 5 Josh Miller 2018-05-18 22:22:36 UTC
The version in testing works for me.

Comment 6 Thomas Moschny 2018-05-19 20:04:51 UTC
*** Bug 1580065 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2018-05-19 22:57:39 UTC
etckeeper-1.18.7-3.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.