Bug 157771 - yaboot, Cann't load "second stage bootstrap"
yaboot, Cann't load "second stage bootstrap"
Status: CLOSED DUPLICATE of bug 158026
Product: Fedora
Classification: Fedora
Component: yaboot (Show other bugs)
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Depends On:
  Show dependency treegraph
Reported: 2005-05-14 21:47 EDT by TAIRA Hajime
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-05-18 10:23:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description TAIRA Hajime 2005-05-14 21:47:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; ja-jp) AppleWebKit/312.1 (KHTML, like Gecko) Safari/312

Description of problem:
I completed install fc4t3-ppc on PowerMac G3 B&W.
After reboot system. yaboot cann't load "second stage bootstrap".

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install fc4t3.

Additional info:
Comment 1 Paul Nasrat 2005-05-16 08:34:30 EDT
Can you boot into OF (cmd option O F)

printenv boot-device
Comment 2 TAIRA Hajime 2005-05-16 09:59:10 EDT
Sorry, Already I Installed Yellow Dog Linux 4 into HDD.
Now I executed printenv command.
Here is output message.

0 > printenv boot-device
------------ Partition: common -------- Signature: 0x70 ----------------
boot-device                 /pci@80000000/pci-bridge@d/pci-ata@1/@0/disk@0:2,¥¥:tbxi hd:,¥¥:tbxi

2month ago, I succeeded in installation of "Unofficial Fedora Core 3 PPC".
I can boot kernel.
Comment 3 Paul Nasrat 2005-05-16 10:17:26 EDT
Can I assume it actually reads \\ rather than ¥¥ - eg hd:,\\:tbxi

If yellow dog can boot the machine using yaboot, we should be able to.  If
you've overwritten the install which will have updated the nvram I can't really
diagnose this.  

If fc3 worked and ydl worked I can't see why fc4t3 would have failed, could you
try another install?
Comment 4 TAIRA Hajime 2005-05-16 10:38:26 EDT
> If you've overwritten the install which will have updated the nvram I can't really diagnose this.  

I think so.

> could you try another install?

When I have time, I will try installation of fc4t3.
Comment 5 Paul Nasrat 2005-05-18 10:13:18 EDT
I believe this to be a duplicate of 157771 which can be worked around by setting
to boot off the yaboot binary. 

I believe this to be an issue with your OF version and the ofboot.b script.  
Please ensure you are running most recent firmware update and note your firmware
version in the bug


Please can you attach a listing of yellowdog's boot partition:

mount -t hfs /dev/hda2 /mnt
ls /mnt

Could you also attach their ofboot.b script.
Comment 6 Paul Nasrat 2005-05-18 10:23:17 EDT
Correction related bug #158026  I'm closing this one as the other one has more
debugging, please add details requested above to that bug.

*** This bug has been marked as a duplicate of 158026 ***

Note You need to log in before you can comment on or make changes to this bug.