Bug 1577751 - the installer hang at nvmem registration failed
Summary: the installer hang at nvmem registration failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-05-14 06:23 UTC by lnie
Modified: 2018-06-01 06:25 UTC (History)
25 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-01 06:25:27 UTC


Attachments (Terms of Use)
screenshot (27.38 KB, image/png)
2018-05-14 06:23 UTC, lnie
no flags Details
screenshot of the boot hang with "quiet" ommiting (41.95 KB, image/png)
2018-05-22 04:42 UTC, lnie
no flags Details

Description lnie 2018-05-14 06:23:08 UTC
Created attachment 1436029 [details]
screenshot

Description of problem:
Boot the installer then you will see the error, there is no way to finish the installation due to the hang.

Version-Release number of selected component (if applicable):
Fedora-Workstation-netinst-x86_64-Rawhide-20180513.n.1.iso

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Martin Kolman 2018-05-14 09:30:51 UTC
This is long before Anaconda starts a could be a kernel issue, so reassigning to the kernel component.

Comment 2 lnie 2018-05-21 11:53:43 UTC
Still happens with the latest Fedora-Workstation-netinst-x86_64-Rawhide-20180519.n.0.iso and Fedora-Server-dvd-x86_64-Rawhide-20180519.n.0.iso

Comment 3 Fedora Blocker Bugs Application 2018-05-21 12:01:47 UTC
Proposed as a Blocker for 29-beta by Fedora user lnie using the blocker tracking app because:

 This affects "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces. "  You can not finish the installation no matter in text,graphical or VNC mode,as the installer will just hang there

Comment 4 lnie 2018-05-21 13:05:39 UTC
This is odd,I try to get more information by omitting the "quiet"kernel option,but the installer boots successfully,then I boot the installer without omitting the option,another successful boot.So this happens occasionally,and in the successful boot you will still see"nvmem registration failed",but the installer will not hang.I  boot the installer on kvm based virtual-machine.

Comment 5 lnie 2018-05-22 04:42:59 UTC
Created attachment 1439838 [details]
screenshot of the boot hang with "quiet" ommiting

Comment 6 lnie 2018-06-01 06:25:27 UTC
Dosen't see this bug any more with the latest Fedora-Workstation-netinst-x86_64-Rawhide-20180531.n.0.iso and Fedora-Server-dvd-x86_64-Rawhide-20180531.n.0.iso,will reopen if I see it again.


Note You need to log in before you can comment on or make changes to this bug.