Bug 1577843 - TSB using origin image when setup using 'oc cluster add' [NEEDINFO]
Summary: TSB using origin image when setup using 'oc cluster add'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Michal Fojtik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-14 09:15 UTC by XiuJuan Wang
Modified: 2018-07-30 19:15 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:15:23 UTC
Target Upstream Version:
jvallejo: needinfo? (deads)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:53 UTC

Description XiuJuan Wang 2018-05-14 09:15:20 UTC
Description of problem:
Template service broker is using openshift/origin-template-service-broker:latest in cluster which is setup using 'oc cluster add template-service-broker'

Version-Release number of selected component (if applicable):

oc v3.10.0-0.41.0
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://127.0.0.1:8443
openshift v3.10.0-0.41.0
kubernetes v1.10.0+b81c8f8


How reproducible:
always

Steps to Reproduce:
1.Setup a cluster using brew image
oc cluster up   --image='brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/ose-${component}:${version}'
2.Add template-service-broker component
oc cluster add template-service-broker  --image='brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/ose-${component}:${version}' --loglevel=8
3.

Actual results:
The template-service-broker is using openshift/origin-template-service-broker:latest

$oc describe  pods -n  openshift-template-service-broker
Name:           apiserver-ftsp2
Namespace:      openshift-template-service-broker
Node:           localhost/172.16.120.90
Start Time:     Mon, 14 May 2018 04:15:49 -0400
Labels:         apiserver=true
                controller-revision-hash=2166077889
                pod-template-generation=1
Annotations:    openshift.io/scc=restricted
Status:         Running
IP:             172.17.0.6

Controlled By:  DaemonSet/apiserver
Containers:
  c:
    Container ID:  docker://3df00b7fdef77a74af08cd6a9ff62c44c9fc2d35967b46447fc1bad7c8223726
    Image:         openshift/origin-template-service-broker:latest
    Image ID:      docker-pullable://docker.io/openshift/origin-template-service-broker@sha256:c6327fb04a4e736448d1c85da2416a4970fc0c7bbbbbd4d3f9895e62ba8f8696
    Port:          8443/TCP
    Host Port:     0/TCP
    Command:
      /usr/bin/template-service-broker
      start
      template-service-broker
      --secure-port=8443
      --audit-log-path=-
      --tls-cert-file=/var/serving-cert/tls.crt
      --tls-private-key-file=/var/serving-cert/tls.key
      -v=0
      --config=/var/apiserver-config/apiserver-config.yaml


Expected results:
Should use the specified image

Additional info:

Comment 2 Juan Vallejo 2018-05-14 21:08:52 UTC
Reassigning to Paul, as this deals with the service catalog

Comment 3 Juan Vallejo 2018-05-15 23:34:17 UTC
David, Michal, based on events I was getting locally, it appears that the kubelet is pulling the "openshift/origin-template-service-broker:latest" image [1].

1. https://github.com/kubernetes/kubernetes/blob/master/pkg/kubelet/images/image_manager.go#L128

`oc get pod -n openshift-template-service-broker` displayed the openshift/origin image in the podSpec, but showed the actual user-specified image under podStatus.

Comment 4 XiuJuan Wang 2018-05-16 03:37:20 UTC
No clusterservicebroker created after installed tsb with openshift/origin-template-service-broker,so no clusterserviceclass shown

Comment 6 Michal Fojtik 2018-05-16 08:22:01 UTC
Fix: https://github.com/openshift/origin/pull/19732

Comment 7 XiuJuan Wang 2018-05-22 03:17:37 UTC
Can't reproduce this bug now
Template-service-broker is using image with specified image.

oc v3.10.0-0.50.0
kubernetes v1.10.0+b81c8f8

Server https://**:8443
openshift v3.10.0-0.50.0
kubernetes v1.10.0+b81c8f8

Comment 9 errata-xmlrpc 2018-07-30 19:15:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.