Bug 1577845 - Geo-rep: faulty session due to OSError: [Errno 95] Operation not supported
Summary: Geo-rep: faulty session due to OSError: [Errno 95] Operation not supported
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.12
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On: 1565399 1567209
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-14 09:24 UTC by Kotresh HR
Modified: 2018-10-23 14:41 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.12.10
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1567209
Environment:
Last Closed: 2018-10-23 14:41:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Kotresh HR 2018-05-14 09:27:58 UTC
Description:

geo-rep sessions ending up faulty due to the following errors:

ssh%3A%2F%2Froot%40171.179.248.2%3Agluster%3A%2F%2F127.0.0.1%3Aamm-remote.log:OSError: [Errno 95] Operation not supported: '.gfid/1d1cad0c-095b-4150-ac7e-734054cd12af'
ssh%3A%2F%2Froot%40171.179.248.2%3Agluster%3A%2F%2F127.0.0.1%3Aamm-remote.log:OSError: [Errno 95] Operation not supported: '.gfid/0218b459-0a04-4466-9afb-8f6eba78f442'

Release version:
3.12

How often does this hit:
Always

Problem:
Geo-rep is not proceeding

Expectation:
Geo-rep should not halt

Comment 2 Kotresh HR 2018-05-14 09:36:38 UTC
https://review.gluster.org/#/c/20017/

Comment 3 Worker Ant 2018-05-14 10:58:09 UTC
REVISION POSTED: https://review.gluster.org/20017 (geo-rep: Fix syncing of symlink) posted (#3) for review on release-3.12 by Kotresh HR

Comment 4 Worker Ant 2018-05-14 10:58:17 UTC
REVIEW: https://review.gluster.org/20017 (geo-rep: Fix syncing of symlink) posted (#3) for review on release-3.12 by Kotresh HR

Comment 5 Worker Ant 2018-06-11 10:17:58 UTC
COMMIT: https://review.gluster.org/20017 committed in release-3.12 by "jiffin tony Thottan" <jthottan@redhat.com> with a commit message- geo-rep: Fix syncing of symlink

Problem:
If symlink is created on master pointing
to current directory (e.g symlink -> ".") with
non root uid or gid, geo-rep worker crashes
with ENOTSUP.

Cause:
Geo-rep creates the symlink on slave and
fixes the uid and gid using chown cmd.
os.chown dereferences the symlink which is
pointing to ".gfid" which is not supported.
Note that geo-rep operates on aux-gfid-mount
(e.g. "/mnt/.gfid/<gfid-of-symlink-file>").

Solution:
The uid or gid change is acutally on symlink
file. So use os.lchown, i.e, don't deference.

Backport of 
> BUG: 1567209
> Patch: https://review.gluster.org/20017

BUG: 1577845
fixes: bz#1577845
Change-Id: I63575fc589d71f987bef1d350c030987738c78ad
Signed-off-by: Kotresh HR <khiremat@redhat.com>

Comment 6 Shyamsundar 2018-10-23 14:41:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.10, please open a new bug report.

glusterfs-3.12.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-May/000099.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.