Bug 1577883 - [UPDATE] After update the tripleo-upgrade check for cinder-volume service on all node and fails (it run only on 1 controller)
Summary: [UPDATE] After update the tripleo-upgrade check for cinder-volume service on...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks: 1488810
TreeView+ depends on / blocked
 
Reported: 2018-05-14 11:16 UTC by Raviv Bar-Tal
Modified: 2018-05-16 16:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-16 16:13:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1771095 None None None 2018-05-14 11:20:58 UTC

Description Raviv Bar-Tal 2018-05-14 11:16:23 UTC
Description of problem:
After update the  tripleo-upgrade check for cinder-volume service on all node and fails (it run only on 1 controller)

Version-Release number of selected component (if applicable):
openstack-tripleo-ui-8.3.1-2.el7ost.noarch
ansible-tripleo-ipsec-8.1.1-0.20180308133440.8f5369a.el7ost.noarch
openstack-tripleo-image-elements-8.0.1-1.el7ost.noarch
openstack-tripleo-validations-8.4.1-4.el7ost.noarch
puppet-tripleo-8.3.2-5.el7ost.noarch
openstack-tripleo-puppet-elements-8.0.0-2.el7ost.noarch
openstack-tripleo-common-containers-8.6.1-7.el7ost.noarch
openstack-tripleo-heat-templates-8.0.2-14.el7ost.noarch
openstack-tripleo-common-8.6.1-7.el7ost.noarch
python-tripleoclient-9.2.1-5.el7ost.noarch


How reproducible:


Steps to Reproduce:
1. install osp13
2. Run the update procedure
3.

Actual results:
update pass

Expected results:
update pass but report as failed from tripleo-upgrade check script

Additional info:
The actual error message from validate_oc_images_containers.log:

Image 192.168.24.1:8787/rhosp13/openstack-cinder-volume:2018-05-07.2 present in /home/stack/virt/docker-images.yaml
PCMKLATEST container for image '192.168.24.1:8787/rhosp13/openstack-cinder-volume:2018-05-07.2' is not running
Running container is ''

Comment 1 Raviv Bar-Tal 2018-05-14 11:18:25 UTC
This is tracker BZ for:
https://bugs.launchpad.net/tripleo/+bug/1771095
"tripleo-upgrade tries to check cinder-volume running on all controllers"

Comment 2 Marius Cornea 2018-05-16 16:13:17 UTC
tripleo-upgrade is a testing tool maintained by Upgrades DFG. We shouldn not keep track of tripleo-upgrade issues in Bugzilla since it's not part of the product that we deliver.


Note You need to log in before you can comment on or make changes to this bug.