Bug 157800 - LE should display the same number of candidates consistently irregardless of client framework
LE should display the same number of candidates consistently irregardless of ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: iiimf-le-chinput (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Qingyu Wang
: i18n
Depends On: 156168
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2005-05-15 20:26 EDT by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 00:40:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-05-15 20:26:30 EDT
Description of problem:
When using chinput, the number of candidates available for users to select from
when using iiimxcf and iiimqcf/iiimgcf varies. IMHO, I feel it should be consistent.

Version-Release number of selected component (if applicable):
iiimf-le-chinput-0.3-19
iiimf-12.2-3

How reproducible:
Always

Steps to Reproduce:
IIIMXCF
1.in g-t, killall iiimx
2.LANG=zh_CN.UTF-8 iiimx &
3.LANG=zh_CN.UTF-8 kedit (default is iiimxcf)
4.ctrl-space, enter 'hong'
5.observe the candidate window  

IIIMGCF
1.in g-t, LANG=zh_CN.UTF-8 gedit 
2.ctrl-space, enter 'hong'
3.observe the candidate window

Actual results:
candidate window in iiimxcf display only one candidate, however, candidate
window in iiimgcf offer more than ten candidates

Expected results:
Number of candidates being displayed should not be determined by client
framework. It should be consistent regardless which client framework used.

Additional info:
Comment 2 Lawrence Lim 2005-10-12 00:40:55 EDT
We strive to work with the upstream community of open source projects. This
allows us to reduce the likelihood of regressions between releases as well as to
benefit from features and fixes as development moves forward. Since this change
would require a divergence from the upstream project, please report this issue
to IIIMF developers by filing a bug report in the OpenI18N bugzilla located at
http://openi18n.org/bugzilla/ in the "IIIMF" component.

We urge you to bring the information upstream, so that it can be incorporated in
the next release. Once you've filed your bug report to OpenI18N, if you paste
the new bug URL here, we will continue to track the issue in the centralized
OpenI18N bug tracker, and will review any bug fixes that become available for
consideration in future updates.

Thanks. 

Note You need to log in before you can comment on or make changes to this bug.