Bug 15781 - Installation bug for people installing RedHat to an image
Installation bug for people installing RedHat to an image
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brock Organ
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2000-08-08 22:03 EDT by Francois Grobbelaar
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-08-15 13:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Francois Grobbelaar 2000-08-08 22:03:55 EDT
When you do a "partitionless" installation using the .img files it
installs fine... however, if you wipe them and then reinstall it still
thinks that space is being used even though its actually empty after
being deleted...

And yes, I do know how to delete the image files... I've tried it several 
times and even tried finding a work around by formatting 6 times and 
trying it, but everytime, i remove the images, boot back into the 
installer and it just still thinks that space is taken up...

(This might be considered major to people who like to install RedHat into 
an image instead, people like me)
Comment 1 Brock Organ 2000-08-10 18:24:03 EDT
Hmmm ... I'm trying to clarify your problem ... please add additional notes if I
am misdiagnosing your issue ... :)

If you install a partitionless install on a vfat partition it will create two


Deleting these files from the underlying vfat partition should allow the space
to be available for use on the vfat partition (even again for another
partitionless install :) )  Are you not seeing this behavior on your system ...?

I'm not sure what you mean by 'wiping' the files (but not deleting them?) ...
are you refering to reformatting the redhat.img file using something like mke2fs
Comment 2 Brock Organ 2000-08-15 13:59:48 EDT
please reopen if I have misdiagnosed your problem above ...
Comment 3 Brock Organ 2000-08-20 10:28:21 EDT
Additional feedback from the bug reporter (sent via email):

Date: Thu, 20 Dec 2001 20:32:35 +1300                                           
From: Francois Grobbelaar <bles@ihug.co.nz>                                     
To: Brock Organ <borgan@redhat.com>                                             
Subject: Re: BUG
I know how to use a computer and the files are not in my recycle bin... I       
know the technical working of a computer, i frikken built my own pc... it is    
a bug in LINUX... I deleted the images, dos and windows shows the space as      
free, but the RedHat installer thinks its still taking up space... Just fix     
Thank you                                                                       
Comment 4 Francois Grobbelaar 2000-08-20 19:56:32 EDT
I wish to re-open the topic cause this hasen't solved anything...

Try it for yourselves, do a partitionless installation, afterwards, delete the 
img files (as in del *.img)... run the setup program again and you'll see it 
still thinks the space is taken up... I also tried this on a test drive and it 
did the same... now please stop e-mailing me with suggestions like "check your 
recycle bin", its a bug... test it, and get rid of it...


Francois Grobbelaar

Note You need to log in before you can comment on or make changes to this bug.