Bug 157818 - (GNOME login) "Could not look up internet address for ..." wont go away
(GNOME login) "Could not look up internet address for ..." wont go away
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-05-16 02:34 EDT by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 16:56:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2005-05-16 02:34:26 EDT
Warning
Could not look up internet address for ibmlaptop.
This will prevent GNOME from operating correctly.
It may be possible to correct the problem by adding ibmlaptop to the file
/etc/hosts.

[Login In Anyway] [Try Again]

I added 'ibmlaptop' to /etc/hosts and clicked 'Try Again'.  GNOME login worked
with the desktop fully loaded.

The warning window comes back and wont go away after hitting either the 'Log in
Anyway' or 'Try Again' buttons.  Killing is the only way to get rid of it.
Comment 1 Ray Strode [halfline] 2005-05-20 16:56:33 EDT
Hi Warren,

This is almost certainly a misconfiguration of your system.  

The real problem is the hostname as called by /bin/hostname doesn't mean much. 
It doesn't need to be externally resolvable, but it often has to be internally
resolvable (things like ORBit and X depend on it).  Really, since the hostname
only has significance to the local machine we shouldn't allow it to get into a
state where this dialog would pop up.  

Also, it's often displayed to the user so it should really be a user friendly
string.  This means just setting it to whatever the dhcp server says is probably
wrong.

Ideally we'd just ask users "what do you want to call your computer?" during
install, put an associated HOSTNAME= line in /etc/sysconfig/network and add a
line to /etc/hosts.  If sysadmins want to maintain a lab of machines that do
automatically get hostnames from dhcp then they can remove the line from
/etc/sysconfig/network manually or use system-config-network.


Note You need to log in before you can comment on or make changes to this bug.