Bug 157819 - Xorg used to work ; Now it doesn't
Xorg used to work ; Now it doesn't
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
http://l-i-e.com/xorgbug/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-16 03:33 EDT by Richard Lynch
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 11:11:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Lynch 2005-05-16 03:33:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02

Description of problem:
The log file is at the URL above, as is xorg.conf

This system has been running fine for months now.

I come home one night, and can't wake up the screen.

I re-boot.

Xorg doesn't work anymore. :-(

I've tried several different kernel versions from grub.

In all cases, grub tries to run the fancy eye candy boot, then fails, and I see
the old school "Starting xyz    [OK]"

Then I get the login prompt, and X tries to run three or four times (screen
flashes to blank, then back to text login).

Finally I get the error message that X is broken.

The final error message is about "Active ring not flushed" whatever that means.

I didn't change anything -- I just came home one day and it was broken. :-(

I *might* have up2date running on auto-pilot, I guess...

If I just have to rollback for awhile, that's fine, but, uh, what do I rollback
and how?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I pretty much just 'shutdown -r now' and pick any kernel from the list...
Okay, I really only tested:
2.6.10-1.8_FC2
2.6.9-1.6_FC2
2.6.5-1.358
so far, but if the newest fails, the one before that fails, and the very first
one I ever had fails, I'm thinking the other kernels ain't likely to work either.

Actual Results:  See description.

Expected Results:  I don't care about the eye candy boot messages, or the fancy-schmancy login
screen, but I kinda need some kind of X Windows to work...


Additional info:

Hey, if you want it, I'll give a RedHat employee or Xorg developer root on the
damn thing for all I care.

Ain't much on the box yet, really...

Just fix the code so I can get back to work on this box.
Comment 1 Richard Lynch 2005-05-16 03:37:07 EDT
Hmph.

The form asked me for a URL ; I gave a URL ; No URL shows up in the report.

Sorry.

http://l-i-e.com/xorgbug/

for xorg.0.log and xorg.conf

Comment 2 Mike A. Harris 2005-05-16 11:11:19 EDT
Fedora Core 2 is now supported by the Fedora Legacy project, and is no
longer supported by Red Hat.  Please upgrade to Fedora Core 3, and apply
all released updates including the latest FC3 kernel, and reboot into the
latest kernel.

Additionally, the above bug report is not really a bug report as it doesn't
give any details of the problem, the hardware, or how to reproduce the
problem.  Without such details, this is a technical support issue, and not
a bug report.  Config and log files must be attached directly to bug
reports, so that they perpetually remain linked to the bug.  Remote URLs
eventually will no longer provide the files once they are removed.

After upgrading to a supported release, if the problem still exists
afterward, join the fedora-list@redhat.com mailing list and/or
xorg@freedesktop.org and describe your problem in as much detail as
possible.  Other users on the lists will provide technical assistance
to help determine wether the problem is an installation issue,
configuration issue, hardware problem, or a real bug

Once it is determined to be a real bug (if it does turn out to be
such), file a bug report in X.Org bugzilla at http://bugs.freedesktop.org
in the "xorg" component so that X.Org developers are aware of the issue
and can hopefully fix it for the next release of X.Org X11.  Should a
bug fix become available from X.Org, Red Hat will review it for consideration
in future updates for supported Fedora Core releases.


Note You need to log in before you can comment on or make changes to this bug.