Bug 1578192 - RHCC Rocketchat APB: Error: /lib64/libz.so.1: version `ZLIB_1.2.9' not found
Summary: RHCC Rocketchat APB: Error: /lib64/libz.so.1: version `ZLIB_1.2.9' not found
Keywords:
Status: CLOSED DUPLICATE of bug 1570462
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Brian Cook
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-15 01:12 UTC by jkim
Modified: 2018-05-15 19:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 19:43:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jkim 2018-05-15 01:12:47 UTC
Description of problem:
The rocketchat/rocketchat-apb from the partner registry [https://registry.connect.redhat.com] does not work after a non-error provision


Version-Release number of selected component (if applicable):
latest

How reproducible:
every time

Steps to Reproduce:
1. configure the broker to use the partner registry
2. provision the rocketchat-apb
3. click on the URL (route) created from provision

Actual results:
Application is not available

Expected results:
Rocketchat WebUI

Additional info:
following is the log shown in the rocketchat pod

Will load cache for users
0 records load from users
Will load cache for rocketchat_room
0 records load from rocketchat_room
Will load cache for rocketchat_subscription
0 records load from rocketchat_subscription
Will load cache for rocketchat_settings
0 records load from rocketchat_settings
Updating process.env.MAIL_URL
Will load cache for rocketchat_permissions
0 records load from rocketchat_permissions
Starting Email Intercepter...
Will load cache for rocketchat_roles
0 records load from rocketchat_roles
Exception in callback of async function: Error: /lib64/libz.so.1: version `ZLIB_1.2.9' not found (required by /opt/app-root/src/bundle/programs/server/npm/node_modules/sharp/build/Release/../../vendor/lib/libpng16.so.16)
    at Object.Module._extensions..node (module.js:672:18)
    at Module.load (module.js:556:32)
    at tryModuleLoad (module.js:499:12)
    at Function.Module._load (module.js:491:3)
    at Module.require (module.js:587:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/opt/app-root/src/bundle/programs/server/npm/node_modules/sharp/lib/constructor.js:10:15)
    at Module._compile (module.js:643:30)
    at Object.Module._extensions..js (module.js:654:10)
    at Module.load (module.js:556:32)
    at tryModuleLoad (module.js:499:12)
    at Function.Module._load (module.js:491:3)
    at Module.require (module.js:587:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/opt/app-root/src/bundle/programs/server/npm/node_modules/sharp/lib/index.js:3:15)
    at Module._compile (module.js:643:30)
    at Object.Module._extensions..js (module.js:654:10)
    at Module.load (module.js:556:32)
    at tryModuleLoad (module.js:499:12)
    at Function.Module._load (module.js:491:3)
    at Module.require (module.js:587:17)
    at require (internal/module.js:11:18)
    at npmRequire (/opt/app-root/src/bundle/programs/server/npm-require.js:133:10)
    at Module.useNode (packages/modules-runtime.js:697:18)
    at fileEvaluate (packages/modules-runtime.js:342:20)
    at require (packages/modules-runtime.js:238:16)
    at FileUpload.js (packages/rocketchat:file-upload/server/lib/FileUpload.js:1:351)
    at fileEvaluate (packages/modules-runtime.js:343:9)
    at require (packages/modules-runtime.js:238:16)
    at /opt/app-root/src/bundle/programs/server/packages/rocketchat_file-upload.js:2254:1
    at /opt/app-root/src/bundle/programs/server/packages/rocketchat_file-upload.js:2268:3
    at /opt/app-root/src/bundle/programs/server/boot.js:411:36
    at Array.forEach (<anonymous>)
    at /opt/app-root/src/bundle/programs/server/boot.js:220:19
    at /opt/app-root/src/bundle/programs/server/boot.js:471:5
    at Function.run (/opt/app-root/src/bundle/programs/server/profile.js:510:12)
    at /opt/app-root/src/bundle/programs/server/boot.js:470:11

Comment 1 John Matthews 2018-05-15 19:43:10 UTC

*** This bug has been marked as a duplicate of bug 1570462 ***


Note You need to log in before you can comment on or make changes to this bug.