Bug 1578381 - Error message need update when specify numa distance with node index >=128
Summary: Error message need update when specify numa distance with node index >=128
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Igor Mammedov
QA Contact: Yumei Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-15 12:44 UTC by Yumei Huang
Modified: 2018-11-08 08:21 UTC (History)
8 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 11:09:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yumei Huang 2018-05-15 12:44:58 UTC
Description of problem:
Boot guest with CLI "-numa dist,src=128,dst=1,val=20", the error message is:

qemu-kvm: -numa dist,src=128,dst=1,val=20: Invalid node 128, max possible could be 128

Which is kind of contradict.

The max index should be 127. The error message need update.


Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.12.0-1.el7
kernel-3.10.0-862.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Boot guest
# /usr/libexec/qemu-kvm -m 24G -smp 16 rhel76-64-virtio-scsi.qcow2 \
-netdev tap,id=tap0 -device virtio-net-pci,id=net0,netdev=tap0 \
-vnc :1 -monitor stdio \
-numa node,nodeid=0 \
-numa node,nodeid=1 \
-numa dist,src=128,dst=1,val=20
2.
3.

Actual results:
QEMU quits with error message:
(qemu) qemu-kvm: -numa dist,src=128,dst=1,val=20: Invalid node 128, max possible could be 128


Expected results:
Error message shows the correct max value or the range.

Additional info:

Comment 2 Igor Mammedov 2018-07-02 13:59:05 UTC
Posted:
"[RHEL-7.6 qemu-kvm-rhev PATCH] numa: clarify error message when node index is out of range in -numa dist, ..."

Comment 4 Miroslav Rezanina 2018-07-04 08:31:03 UTC
Fix included in qemu-kvm-rhev-2.12.0-7.el7

Comment 6 Yumei Huang 2018-07-05 05:05:32 UTC
Verify:
qemu-kvm-rhev-2.12.0-7.el7

# /usr/libexec/qemu-kvm -numa node,nodeid=0 -numa node,nodeid=1 -numa dist,src=128,dst=1,val=20
qemu-kvm: -numa dist,src=128,dst=1,val=20: Parameter 'src' expects an integer between 0 and 127


# /usr/libexec/qemu-kvm -numa node,nodeid=0 -numa node,nodeid=1 -numa dist,src=1,dst=128,val=20
qemu-kvm: -numa dist,src=1,dst=128,val=20: Parameter 'dst' expects an integer between 0 and 127

Comment 7 errata-xmlrpc 2018-11-01 11:09:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.