Bug 1578404 - Fetch engine logs from the engine VM
Summary: Fetch engine logs from the engine VM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.19
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.4
: 2.2.21
Assignee: Ido Rosenzwig
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: ovirt-hosted-engine-setup-2.2.22
TreeView+ depends on / blocked
 
Reported: 2018-05-15 13:59 UTC by Simone Tiraboschi
Modified: 2018-06-26 08:37 UTC (History)
3 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.21
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:37:29 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90404 0 ovirt-hosted-engine-setup-2.2 MERGED refactor out get_local_vm_disk_path.yml 2018-05-23 12:04:56 UTC
oVirt gerrit 90405 0 ovirt-hosted-engine-setup-2.2 MERGED ansible: logs: fetch logs from the engine VM 2018-05-23 12:04:59 UTC
oVirt gerrit 91051 0 ovirt-hosted-engine-setup-2.2 MERGED ansible: avoid failing at log extraction 2018-05-23 12:05:01 UTC

Description Simone Tiraboschi 2018-05-15 13:59:03 UTC
Description of problem:
For debug purposes and post failures analysis, ovirt-hosted-engine-setup should fetch engine and host-deploy logs from the engine VM via guestfish.

Version-Release number of selected component (if applicable):
2.2.20

How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine
2.
3.

Actual results:
engine.log and host-deploy logs are just on the engine VM so they are not accessible if the engine VM is not accessible.

Expected results:
relevant engine logs get copied to /var/log/ovirt-hosted-engine-setup/engine-logs... on the host

Additional info:

Comment 1 Yaniv Kaul 2018-05-16 07:20:45 UTC
Severity...?

Comment 2 Doron Fediuck 2018-05-16 07:39:36 UTC
Once available, it would be helpful to show it in the cockpit wizard (assuming something failed and the user needs to change his settings).

Comment 3 Simone Tiraboschi 2018-05-16 08:03:10 UTC
(In reply to Yaniv Kaul from comment #1)
> Severity...?

It's just a nice to have.
But we already have it on master, I think it could be worth to backport it to 4.2.4.

Comment 4 Nikolai Sednev 2018-06-05 14:09:08 UTC
alma04 ~]# ll -lsha /var/log/ovirt-hosted-engine-setup/engine-logs-2018-06-05T13:16:14Z/
total 124K
4.0K drwx------.  3 root root 4.0K Jun  5 16:16 .
4.0K drwx------.  5 root root 4.0K Jun  5 16:16 ..
112K -rw-r--r--.  1 root root 108K Jun  5 16:16 messages
4.0K drwx------. 12  108  108 4.0K Jun  5 15:48 ovirt-engine

alma04 ~]# ll -lsha /var/log/ovirt-hosted-engine-setup/engine-logs-2018-06-05T13:16:14Z/ovirt-engine
total 400K
4.0K drwx------. 12  108  108 4.0K Jun  5 15:48 .
4.0K drwx------.  3 root root 4.0K Jun  5 16:16 ..
4.0K drwx------.  2  108  108 4.0K May 30 20:45 ansible
4.0K -rw-r--r--.  1  108  108 2.2K Jun  5 15:48 boot.log
4.0K drwx------.  2  108  108 4.0K May 30 20:45 brick-setup
   0 -rw-r--r--.  1  108  108    0 Jun  5 15:48 console.log
4.0K drwx------.  2  108  108 4.0K May 30 20:45 db-manual
4.0K drwx------.  2  108  108 4.0K May 30 20:45 dump
276K -rw-r--r--.  1  108  108 270K Jun  5 15:59 engine.log
4.0K drwx------.  2  108  108 4.0K Jun  5 15:49 host-deploy
4.0K drwx------.  2  108  108 4.0K May 30 20:45 notifier
4.0K drwx------.  2  108  108 4.0K May 30 20:45 ova
4.0K drwxr-xr-x.  2 root root 4.0K Feb 14 11:01 ovirt-iso-uploader
4.0K drwxr-xr-x.  2 root root 4.0K May 24 17:38 ovirt-log-collector
 72K -rw-r--r--.  1  108  108  68K Jun  5 15:59 server.log
4.0K drwx------.  2 root root 4.0K Jun  5 15:45 setup
   0 -rw-r--r--.  1  108  108    0 Jun  5 15:48 ui.log
alma04 ~]# cd /var/log/ovirt-hosted-engine-setup/
[root@alma04 ovirt-hosted-engine-setup]# tree
.
├── engine-logs-2018-06-05T11:23:15Z
├── engine-logs-2018-06-05T12:08:19Z
│   ├── messages
│   └── ovirt-engine
│       ├── ansible
│       ├── boot.log
│       ├── brick-setup
│       ├── console.log
│       ├── db-manual
│       ├── dump
│       ├── engine.log
│       ├── host-deploy
│       │   ├── ovirt-host-deploy-20180605143523-alma04.qa.lab.tlv.redhat.com-561d2232.log
│       │   └── ovirt-host-deploy-ansible-20180605143524-alma04.qa.lab.tlv.redhat.com-561d2232.log
│       ├── notifier
│       ├── ova
│       ├── ovirt-iso-uploader
│       ├── ovirt-log-collector
│       ├── server.log
│       ├── setup
│       │   └── ovirt-engine-setup-20180605143042-vuoii1.log
│       └── ui.log
├── engine-logs-2018-06-05T13:16:14Z
│   ├── messages
│   └── ovirt-engine
│       ├── ansible
│       ├── boot.log
│       ├── brick-setup
│       ├── console.log
│       ├── db-manual
│       ├── dump
│       ├── engine.log
│       ├── host-deploy
│       │   ├── ovirt-host-deploy-20180605154950-alma04.qa.lab.tlv.redhat.com-6717b2af.log
│       │   └── ovirt-host-deploy-ansible-20180605154951-alma04.qa.lab.tlv.redhat.com-6717b2af.log
│       ├── notifier
│       ├── ova
│       ├── ovirt-iso-uploader
│       ├── ovirt-log-collector
│       ├── server.log
│       ├── setup
│       │   └── ovirt-engine-setup-20180605154507-jmev5e.log
│       └── ui.log
├── ovirt-hosted-engine-setup-20180605140844-ep2xya.log
├── ovirt-hosted-engine-setup-20180605142358-jgiwkg.log
├── ovirt-hosted-engine-setup-20180605152554-ae7ky3.log
├── ovirt-hosted-engine-setup-20180605153759-5kt57x.log
├── ovirt-hosted-engine-setup-ansible-bootstrap_local_vm-20180605141006-d1j4ho.log
├── ovirt-hosted-engine-setup-ansible-bootstrap_local_vm-20180605142531-gsnfm9.log
├── ovirt-hosted-engine-setup-ansible-bootstrap_local_vm-20180605152728-qh7srn.log
├── ovirt-hosted-engine-setup-ansible-bootstrap_local_vm-20180605153933-ex5c7a.log
├── ovirt-hosted-engine-setup-ansible-create_storage_domain-20180605144213-567dnc.log
├── ovirt-hosted-engine-setup-ansible-create_storage_domain-20180605155322-xwqima.log
├── ovirt-hosted-engine-setup-ansible-create_target_vm-20180605144702-afqknc.log
├── ovirt-hosted-engine-setup-ansible-create_target_vm-20180605155533-rafnjz.log
├── ovirt-hosted-engine-setup-ansible-final_clean-20180605142312-9bk90y.log
├── ovirt-hosted-engine-setup-ansible-final_clean-20180605150816-0k1xaq.log
├── ovirt-hosted-engine-setup-ansible-final_clean-20180605153734-fh4zvw.log
├── ovirt-hosted-engine-setup-ansible-final_clean-20180605161611-m3lfgp.log
├── ovirt-hosted-engine-setup-ansible-get_network_interfaces-20180605140855-zbjaij.log
├── ovirt-hosted-engine-setup-ansible-get_network_interfaces-20180605142415-l8s6l6.log
├── ovirt-hosted-engine-setup-ansible-get_network_interfaces-20180605152608-o3lzxx.log
├── ovirt-hosted-engine-setup-ansible-get_network_interfaces-20180605153809-ksobn6.log
├── ovirt-hosted-engine-setup-ansible-initial_clean-20180605140938-9uqhvi.log
├── ovirt-hosted-engine-setup-ansible-initial_clean-20180605142459-ofxhi7.log
├── ovirt-hosted-engine-setup-ansible-initial_clean-20180605152652-ie5woo.log
├── ovirt-hosted-engine-setup-ansible-initial_clean-20180605153856-6p03eq.log
├── ovirt-hosted-engine-setup-ansible-iscsi_discover-20180605144137-1rzry0.log
├── ovirt-hosted-engine-setup-ansible-iscsi_discover-20180605155244-ts74tt.log
├── ovirt-hosted-engine-setup-ansible-iscsi_getdevices-20180605144154-nsrq8p.log
└── ovirt-hosted-engine-setup-ansible-iscsi_getdevices-20180605155304-41b1gx.log

25 directories, 46 files


Works for me on these components:
ovirt-hosted-engine-ha-2.2.13-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.22-1.el7ev.noarch
rhvm-appliance-4.2-20180601.0.el7.noarch
Linux 3.10.0-862.3.2.el7.x86_64 #1 SMP Tue May 15 18:22:15 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)


Moving to verified.

Comment 5 Sandro Bonazzola 2018-06-26 08:37:29 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.