Bug 1578501 - glusterd does not start with selinux in enforcing mode
Summary: glusterd does not start with selinux in enforcing mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-15 17:37 UTC by Torben Jaeger
Modified: 2018-05-26 20:43 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.14.1-29.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-26 20:43:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Torben Jaeger 2018-05-15 17:37:00 UTC
Description of problem:

May 15 19:08:29 tower.localdomain systemd[1]: Starting GlusterFS, a clustered file-system server...
-- Subject: Unit glusterd.service has begun start-up
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit glusterd.service has begun starting up.
May 15 19:08:29 tower.localdomain audit[5124]: AVC avc:  denied  { dac_override } for  pid=5124 comm="glusterd" capability=1  scontext=system_u:system_r:glusterd_t:s0 tcontext=system_u:system_r:glusterd_t:s0 tclass=capability permissive=0
May 15 19:08:29 tower.localdomain glusterd[5124]: [2018-05-15 17:08:29.632650] C [MSGID: 106031] [glusterd.c:1324:glusterd_init_var_run_dirs] 0-management: Unable to create directory /run/gluster/snaps ,errno = 13 [Permission denied]
May 15 19:08:29 tower.localdomain glusterd[5124]: [2018-05-15 17:08:29.632734] C [MSGID: 106031] [glusterd.c:1502:init] 0-management: Unable to create snap backend folder
May 15 19:08:29 tower.localdomain systemd[1]: glusterd.service: Control process exited, code=exited status=1
May 15 19:08:29 tower.localdomain systemd[1]: glusterd.service: Failed with result 'exit-code'.
May 15 19:08:29 tower.localdomain systemd[1]: Failed to start GlusterFS, a clustered file-system server.
-- Subject: Unit glusterd.service has failed
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit glusterd.service has failed.
--
-- The result is RESULT.
May 15 19:08:29 tower.localdomain audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=glusterd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'



% sudo sealert -l 81e8501a-9a28-404f-acb4-26367d8feada
SELinux is preventing glusteriotwr0 from using the dac_override capability.

*****  Plugin dac_override (91.4 confidence) suggests   **********************

If you want to help identify if domain needs this access or you have a file with the wrong permissions on your system
Then turn on full auditing to get path information about the offending file and generate the error again.
Do

Turn on full auditing
# auditctl -w /etc/shadow -p w
Try to recreate AVC. Then execute
# ausearch -m avc -ts recent
If you see PATH record check ownership/permissions on file, and fix it,
otherwise report as a bugzilla.

*****  Plugin catchall (9.59 confidence) suggests   **************************

If you believe that glusteriotwr0 should have the dac_override capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'glusteriotwr0' --raw | audit2allow -M my-glusteriotwr0
# semodule -X 300 -i my-glusteriotwr0.pp


Additional Information:
Source Context                system_u:system_r:glusterd_t:s0
Target Context                system_u:system_r:glusterd_t:s0
Target Objects                Unknown [ capability ]
Source                        glusteriotwr0
Source Path                   glusteriotwr0
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages
Target RPM Packages
Policy RPM                    selinux-policy-3.14.1-24.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     tower.localdomain
Platform                      Linux tower.localdomain 4.16.8-300.fc28.x86_64 #1
                              SMP Wed May 9 20:23:40 UTC 2018 x86_64 x86_64
Alert Count                   70
First Seen                    2018-04-13 22:02:27 CEST
Last Seen                     2018-05-15 19:08:29 CEST
Local ID                      81e8501a-9a28-404f-acb4-26367d8feada

Raw Audit Messages
type=AVC msg=audit(1526404109.632:283): avc:  denied  { dac_override } for  pid=5124 comm="glusterd" capability=1  scontext=system_u:system_r:glusterd_t:s0 tcontext=system_u:system_r:glusterd_t:s0 tclass=capability permissive=0


Hash: glusteriotwr0,glusterd_t,glusterd_t,capability,dac_override


Version-Release number of selected component (if applicable):

$ cat /etc/redhat-release 
Fedora release 28 (Twenty Eight)

$ uname -a
Linux localhost.localdomain 4.16.8-300.fc28.x86_64 #1 SMP Wed May 9 20:23:40 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

% sudo dnf list gluster\*
Last metadata expiration check: 3:16:03 ago on Tue 15 May 2018 04:19:26 PM CEST.
Installed Packages
glusterfs.x86_64                                                 4.0.2-1.fc28                                  @updates
glusterfs-api.x86_64                                             4.0.2-1.fc28                                  @updates
glusterfs-cli.x86_64                                             4.0.2-1.fc28                                  @updates
glusterfs-client-xlators.x86_64                                  4.0.2-1.fc28                                  @updates
glusterfs-fuse.x86_64                                            4.0.2-1.fc28                                  @updates
glusterfs-libs.x86_64                                            4.0.2-1.fc28                                  @updates
glusterfs-server.x86_64                                          4.0.2-1.fc28                                  @updates

% sudo dnf list selinux\*
Last metadata expiration check: 3:14:59 ago on Tue 15 May 2018 04:19:26 PM CEST.
Installed Packages
selinux-policy.noarch                                          3.14.1-24.fc28                                  @updates
selinux-policy-targeted.noarch                                 3.14.1-24.fc28                                  @updates


How reproducible:


Steps to Reproduce:
1. setenforce 1
2. systemctl start glusterd
3.

Actual results:

% sudo systemctl status glusterd
[sudo] password for torben: 
● glusterd.service - GlusterFS, a clustered file-system server
   Loaded: loaded (/usr/lib/systemd/system/glusterd.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2018-05-15 19:08:29 CEST; 25min ago
  Process: 5123 ExecStart=/usr/sbin/glusterd -p /var/run/glusterd.pid --log-level $LOG_LEVEL $GLUSTERD_OPTIONS (code=e>

May 15 19:08:29 tower.localdomain systemd[1]: Starting GlusterFS, a clustered file-system server...
May 15 19:08:29 tower.localdomain glusterd[5124]: [2018-05-15 17:08:29.632650] C [MSGID: 106031] [glusterd.c:1324:glus>
May 15 19:08:29 tower.localdomain glusterd[5124]: [2018-05-15 17:08:29.632734] C [MSGID: 106031] [glusterd.c:1502:init>
May 15 19:08:29 tower.localdomain systemd[1]: glusterd.service: Control process exited, code=exited status=1
May 15 19:08:29 tower.localdomain systemd[1]: glusterd.service: Failed with result 'exit-code'.
May 15 19:08:29 tower.localdomain systemd[1]: Failed to start GlusterFS, a clustered file-system server.



Expected results:
glusterd running

Additional info:

Comment 1 Fedora Update System 2018-05-24 14:35:00 UTC
selinux-policy-3.14.1-29.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a74875b364

Comment 2 Fedora Update System 2018-05-25 18:42:00 UTC
selinux-policy-3.14.1-29.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a74875b364

Comment 3 Fedora Update System 2018-05-26 20:43:48 UTC
selinux-policy-3.14.1-29.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.