Bug 1578514 - libreport update stumbles upon broken dependencies
Summary: libreport update stumbles upon broken dependencies
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 1578359
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-15 18:43 UTC by Michal Jaegermann
Modified: 2018-05-21 08:03 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-05-21 08:03:02 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2018-05-15 18:43:20 UTC
Description of problem:

On the current rawhide attempt to do 'dnf update libreport' results in

Error: 
 Problem: cannot install both libreport-2.9.5-1.fc29.x86_64 and libreport-2.9.4-1.fc29.x86_64
  - package python2-libreport-2.9.4-1.fc29.x86_64 requires libreport = 2.9.4-1.fc29, but none of the providers can be installed
  - cannot install the best update candidate for package libreport-2.9.4-1.fc29.x86_64
  - problem with installed package python2-libreport-2.9.4-1.fc29.x86_64

If 'python2-libreport' is no longer desired than it looks like that corresponding "obsoletes" was forgotten.

Version-Release number of selected component (if applicable):
libreport-2.9.5-1.fc29

Additional info:
Running with an additional '--allowerasing' allows this update to proceed.

Comment 1 Matej Habrnal 2018-05-21 08:03:02 UTC
Done by https://bugzilla.redhat.com/show_bug.cgi?id=1578359


Note You need to log in before you can comment on or make changes to this bug.