Bug 1578525 - Needs rebuild for RHEL 7.5
Summary: Needs rebuild for RHEL 7.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pyexiv2
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Oliver Haessler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-15 19:05 UTC by Anssi Johansson
Modified: 2019-01-09 12:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 17:04:09 UTC


Attachments (Terms of Use)

Description Anssi Johansson 2018-05-15 19:05:11 UTC
Description of problem:
exiv2-libs was updated in RHEL 7.5. It now provides libexiv2.so.26 instead of libexiv2.so.12, and pyexiv2 would need to be rebuilt against the new exiv2-libs.

Version-Release number of selected component (if applicable):
pyexiv2-0.3.2-22.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have CentOS/RHEL 7.5
2. "yum install pyexiv2"

Actual results:
--> Finished Dependency Resolution
Error: Package: pyexiv2-0.3.2-22.el7.x86_64 (epel)
           Requires: libexiv2.so.12()(64bit)

Expected results:
Package gets installed.

Comment 1 Akemi Yagi 2018-06-27 22:21:42 UTC
Is this being worked on? Any update much appreciated.

Comment 2 Fedora Update System 2018-06-28 12:52:26 UTC
pyexiv2-0.3.2-35.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-278a043e0c

Comment 3 Fedora Update System 2018-06-29 09:41:12 UTC
pyexiv2-0.3.2-35.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-278a043e0c

Comment 4 Oliver Haessler 2018-12-10 13:28:09 UTC
I have tried this on RHEL 7.6 and I do not see the issue.

yum install pyexiv2

it is installing boost-python and compat-exiv2-023

Do I miss anything?

Installing:
 pyexiv2                 x86_64        0.3.2-22.el7           production-rhel-x86_64-workstation-epel-7.6        259 k
Installing for dependencies:
 boost-python            x86_64        1.53.0-27.el7          production-rhel-x86_64-workstation-7.6             129 k
 compat-exiv2-023        x86_64        0.23-2.el7             production-rhel-x86_64-workstation-7.6             681 k

Comment 5 Anssi Johansson 2018-12-10 13:37:14 UTC
This was an issue in 7.5, but in 7.6 RH unbroke it by introducing that new compat-exiv2-023 package. That package did not exist in 7.5.

Nevertheless, I would think it would be wiser to have pyexiv2 linked against the new exiv2-libs so that compat-exiv2-023 would not be needed. In fact the rebuild has already been done in https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-278a043e0c but for some reason that update to pyexiv2 hasn't been pushed to stable yet.

Comment 6 Oliver Haessler 2018-12-10 13:44:07 UTC
Thanks for the feedback. I just double checked and it seems I just missed to push the update to stable. I have requested the push to stable now.

Comment 7 Randy Barlow 2018-12-11 17:04:09 UTC
A Fedora update associated with this bug has been pushed to the stable repository.

Comment 8 Randy Barlow 2018-12-14 20:41:19 UTC
A Fedora update associated with this bug has been pushed to the stable repository.


Note You need to log in before you can comment on or make changes to this bug.