Bug 157859 - Installation crashes on my PowerBook G4
Installation crashes on my PowerBook G4
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
4
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 157965 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-16 11:12 EDT by Dietze Sebastian
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 21:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dietze Sebastian 2005-05-16 11:12:23 EDT
Description of problem:

If i boot from the DVD, then linux starts normaly. After anaconda has check the
system components it want to start the X-server. Now nothing happens. I can not
switch to a console.

Version-Release number of selected component (if applicable):


How reproducible:

Try to install Fedora 4 Test 3 from a DVD on a PowerBook G4.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
My system:
PowerBook G4 - 1,5 GHz PowerPC
1,25 GB RAM
80 MB HD
ATI Mobility Radeon 9700 - 64 MB RAM
Comment 1 Mike A. Harris 2005-05-16 13:11:25 EDT
Do a text mode installation, then reconfigure the X server with:

system-config-display --reconfig

Does the X server start correctly now?

If the server doesn't start, file a bug report in X.Org bugzilla
in "xorg" component against PPC platform at http://bugs.freedesktop.org
and attach your X server log and config file to the X.Org bug report.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.
Comment 2 Mike A. Harris 2005-05-16 13:11:56 EDT
Setting status to "NEEDINFO", awaiting update, and upstream bug URL.
Comment 3 Dietze Sebastian 2005-05-17 14:56:35 EDT
After calling:

system-config-display --reconfig 

the same behavior happens. 

The X.Org bugzilla url is: https://bugs.freedesktop.org/show_bug.cgi?id=3318 





(In reply to comment #1)
> Do a text mode installation, then reconfigure the X server with:
> 
> system-config-display --reconfig
> 
> Does the X server start correctly now?
> 
> If the server doesn't start, file a bug report in X.Org bugzilla
> in "xorg" component against PPC platform at http://bugs.freedesktop.org
> and attach your X server log and config file to the X.Org bug report.
> 
> Once you've filed your bug report to X.Org, if you paste the new
> bug URL here, Red Hat will continue to track the issue in the
> centralized X.Org bug tracker, and will review any bug fixes that
> become available for consideration in future updates.
Comment 4 Mike A. Harris 2005-05-18 21:07:27 EDT
Ok thanks.  Adding bug to our "UPSTREAM" tracker.  Please make any further
comments, etc. in the X.org bug, and we'll track it there.

Comment 5 Mike A. Harris 2005-05-26 04:03:14 EDT
*** Bug 157965 has been marked as a duplicate of this bug. ***
Comment 6 Frank Arnold 2005-06-28 13:37:41 EDT
Finally found some time to investigate this a little bit.
My system: Recent Apple Powerbook G4 15" (Powerbook5,6) with Mobility Radeon
9600 M10

The problem seems to be caused by a fedora patch. Namely this one:
http://cvs.fedora.redhat.com/viewcvs/rpms/xorg-x11/devel/xorg-x11-6.8.1-ati-radeon-dynamic-clocks-fix-2.patch

Tried the latest development package (release 38) with the same results as
before. After rebuilding the package with exclusion of the patch mentioned above
everything works fine.

Perhaps this bug should be reopened because this patch is not part of recent
xorg sources. Added the same comment to X.Org bug report.

Note You need to log in before you can comment on or make changes to this bug.