Bug 1578614 - [svcat] Should display "Parameters From" in svcat describe instance/binding output
Summary: [svcat] Should display "Parameters From" in svcat describe instance/binding o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Marko Luksa
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-16 02:26 UTC by sunzhaohua
Modified: 2018-07-30 19:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:15:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:54 UTC

Description sunzhaohua 2018-05-16 02:26:27 UTC
Description of problem:
Should display "Parameters From" in svcat describe instance/binding output

Version-Release number of selected component (if applicable):
svcat:
client: v3.10.0-0.38.0;Upstream:v0.1.16
server: v1.10.0+b81c8f8

How reproducible:
Always

Steps to Reproduce:
1. provision an instance with "--secret" option
2. describe instance
3. bind an instance
4. describe  binding

Actual results:
If you reference a secret in your serviceinstance/servicebinding, there are no information about the secret in the describe output.

# svcat provision -n szh-project ups-instance7 --class user-provided-service --plan default --param location=eastus --secret my-secret[parameters]
  Name:        ups-instance7          
  Namespace:   szh-project            
  Status:                             
  Class:       user-provided-service  
  Plan:        default                

Parameters:
  location: eastus

# svcat describe instance ups-instance7  
  Name:        ups-instance7                                                                      
  Namespace:   szh-project                                                                        
  Status:      Ready - The instance was provisioned successfully @ 2018-05-15 08:27:13 +0000 UTC  
  Class:       user-provided-service                                                              
  Plan:        default                                                                            

Parameters:
  location: eastus

Bindings:
No bindings defined

# oc describe serviceinstance ups-instance7
...
Spec:
  Parameters:
    Location:  eastus
  Parameters From:
    Secret Key Ref:
      Key:          parameters
      Name:         my-secret
  Update Requests:  0
...
 
# svcat bind ups-instance7 --name ups-instance1-bind1 --param location=eastus -s my-secret[parameters]
  Name:        ups-instance1-bind1  
  Namespace:   szh-project          
  Status:                           
  Secret:      ups-instance1-bind1  
  Instance:    ups-instance7        

Parameters:
  location: eastus

# svcat describe binding ups-instance1-bind1
  Name:        ups-instance1-bind1                                           
  Namespace:   szh-project                                                   
  Status:      Ready - Injected bind result @ 2018-05-15 08:40:58 +0000 UTC  
  Secret:      ups-instance1-bind1                                           
  Instance:    ups-instance7                                                 

Parameters:
  location: eastus

Secret Data:
  special-key-1   15 bytes  
  special-key-2   15 bytes

# oc describe servicebinding ups-instance1-bind1
.....
Spec:
  Parameters:
    Location:  eastus
  Parameters From:
    Secret Key Ref:
      Key:      parameters
      Name:     my-secret
  Secret Name:  ups-instance1-bind1
...
Expected results:
There are related information about the secret in the describe output

Additional info:

Comment 1 Marko Luksa 2018-05-17 12:31:44 UTC
PR submitted: https://github.com/kubernetes-incubator/service-catalog/pull/2043

Comment 2 Marko Luksa 2018-05-18 06:48:55 UTC
PR has been merged.

Comment 4 sunzhaohua 2018-05-22 10:02:19 UTC
 image is ready, change it to ON-QA

Comment 5 sunzhaohua 2018-05-22 10:03:45 UTC
Verified.

[root@ip-172-18-12-36 ~]# svcat version
client: v3.10.0-0.50.0;Upstream:v0.1.19
server: v1.10.0+b81c8f8


[root@ip-172-18-12-36 ~]#  svcat provision -n szh-project ups-instance7 --class user-provided-service --plan default --param location=eastus --secret my-secret[parameters]
  Name:        ups-instance7          
  Namespace:   szh-project            
  Status:                             
  Class:       user-provided-service  
  Plan:        default                

Parameters:
  location: eastus

Parameters From:
  Secret: my-secret.parameters
[root@ip-172-18-12-36 ~]# svcat describe instance ups-instance7  
  Name:        ups-instance7                                                                      
  Namespace:   szh-project                                                                        
  Status:      Ready - The instance was provisioned successfully @ 2018-05-22 10:00:53 +0000 UTC  
  Class:       user-provided-service                                                              
  Plan:        default                                                                            

Parameters:
  location: eastus

Parameters From:
  Secret: my-secret.parameters

Bindings:
No bindings defined
[root@ip-172-18-12-36 ~]# oc describe serviceinstance ups-instance7
Name:         ups-instance7
Namespace:    szh-project
Labels:       <none>
Annotations:  <none>
API Version:  servicecatalog.k8s.io/v1beta1
Kind:         ServiceInstance
Metadata:
  Creation Timestamp:  2018-05-22T10:00:52Z
  Finalizers:
    kubernetes-incubator/service-catalog
  Generation:        1
  Resource Version:  63694
  Self Link:         /apis/servicecatalog.k8s.io/v1beta1/namespaces/szh-project/serviceinstances/ups-instance7
  UID:               0339de49-5da7-11e8-8fb0-0a580a800004
Spec:
  Cluster Service Class External Name:  user-provided-service
  Cluster Service Class Ref:
    Name:                              4f6e6cf6-ffdd-425f-a2c7-3c9258ad2468
  Cluster Service Plan External Name:  default
  Cluster Service Plan Ref:
    Name:       86064792-7ea2-467b-af93-ac9694d96d52
  External ID:  0339ddc5-5da7-11e8-8fb0-0a580a800004
  Parameters:
    Location:  eastus
  Parameters From:
    Secret Key Ref:
      Key:          parameters
      Name:         my-secret
  Update Requests:  0
  User Info:
    Extra:
      Scopes . Authorization . Openshift . Io:
        user:full
    Groups:
      system:authenticated:oauth
      system:authenticated
    UID:       
    Username:  zhsun
Status:
  Async Op In Progress:  false
  Conditions:
    Last Transition Time:  2018-05-22T10:00:53Z
    Message:               The instance was provisioned successfully
    Reason:                ProvisionedSuccessfully
    Status:                True
    Type:                  Ready
  Deprovision Status:      Required
  External Properties:
    Cluster Service Plan External ID:    86064792-7ea2-467b-af93-ac9694d96d52
    Cluster Service Plan External Name:  default
    Parameter Checksum:                  afbcd82da3c33d81c2935d242dcb1d1c29fc673e9830b7969d0d643116631836
    Parameters:
      DATABASE _ SERVICE _ NAME:  <redacted>
      MEMORY _ LIMIT:             <redacted>
      NAMESPACE:                  <redacted>
      POSTGRESQL _ DATABASE:      <redacted>
      POSTGRESQL _ VERSION:       <redacted>
      VOLUME _ CAPACITY:          <redacted>
      Location:                   eastus
    User Info:
      Extra:
        Scopes . Authorization . Openshift . Io:
          user:full
      Groups:
        system:authenticated:oauth
        system:authenticated
      UID:                        
      Username:                   zhsun
  Observed Generation:            1
  Orphan Mitigation In Progress:  false
  Provision Status:               Provisioned
  Reconciled Generation:          1
Events:
  Type    Reason                   Age   From                                Message
  ----    ------                   ----  ----                                -------
  Normal  ProvisionedSuccessfully  31s   service-catalog-controller-manager  The instance was provisioned successfully
[root@ip-172-18-12-36 ~]# svcat bind ups-instance7 --name ups-instance1-bind1 --param location=eastus -s my-secret[parameters]
  Name:        ups-instance1-bind1  
  Namespace:   szh-project          
  Status:                           
  Secret:      ups-instance1-bind1  
  Instance:    ups-instance7        

Parameters:
  location: eastus

Parameters From:
  Secret: my-secret.parameters
[root@ip-172-18-12-36 ~]# svcat describe binding ups-instance1-bind1
  Name:        ups-instance1-bind1                                           
  Namespace:   szh-project                                                   
  Status:      Ready - Injected bind result @ 2018-05-22 10:01:46 +0000 UTC  
  Secret:      ups-instance1-bind1                                           
  Instance:    ups-instance7                                                 

Parameters:
  location: eastus

Parameters From:
  Secret: my-secret.parameters

Secret Data:
  special-key-1   15 bytes  
  special-key-2   15 bytes

Comment 7 errata-xmlrpc 2018-07-30 19:15:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.