Bug 1578650 - If parallel-readdir is enabled, the readdir-optimize option even when it is set to on it behaves as off
Summary: If parallel-readdir is enabled, the readdir-optimize option even when it is s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: read-ahead
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1578647
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-16 05:37 UTC by Poornima G
Modified: 2018-10-23 15:09 UTC (History)
6 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1578647
Environment:
Last Closed: 2018-10-23 15:09:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Poornima G 2018-05-16 05:37:55 UTC
+++ This bug was initially created as a clone of Bug #1578647 +++

Description of problem:
=======================
While trying to reproduce https://bugzilla.redhat.com/show_bug.cgi?id=1529072 on a build older than the fix, it is found that if parallel-readdir is enabled, the readdir-optimize option even when it is set to on it is behaving as off.

Version-Release number of selected component (if applicable):
3.12.2-9.el7rhgs.x86_64

How reproducible:
always

Steps to Reproduce:
===================
There are no specific steps to reproduce this issue. It can be reproduced by attaching gdb or by looking at tcpdump wireshark.

Actual results:
================
When parallel-readdir is enabled, the readdir-optimize option when set to on it is behaving as off.

Expected results:
=================
When parallel-readdir is enabled, the readdir-optimize option when set to on should continue as on.

Comment 1 Worker Ant 2018-05-16 05:40:13 UTC
REVIEW: https://review.gluster.org/20026 (readdir-ahead: Fix an issue with parallel-readdir and readdir-optimize                interaction) posted (#1) for review on master by Poornima G

Comment 2 Worker Ant 2018-05-17 06:48:21 UTC
COMMIT: https://review.gluster.org/20026 committed in master by "Raghavendra G" <rgowdapp@redhat.com> with a commit message- readdir-ahead: Fix an issue with parallel-readdir and readdir-optimize

Issue: When parallel-readdir is enabled, readdir-optimize automatically
stops working because of a bug in rda_opendir.

RCA: In rda_opendir, the xattrs that indicate readdir-optimize or not
is sent in xdata. This xdata is sent to all the readdirp prefetch
calls. A dict_ref is taken on xdata and kept in rda_opendir to be
used by rda_fill_fd, but dht_opendir deletes some elements in xdata
after calling rda_opendir. Hence dict_ref is not a right choice here,
dict_copy needs to used.

Change-Id: Ie7cc7ceb03117dd4179ef7905647f2f123f94966
fixes: bz#1578650
Signed-off-by: Poornima G <pgurusid@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:09:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.