This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 157874 - mktemp needs '-t' option
mktemp needs '-t' option
Status: CLOSED DUPLICATE of bug 133416
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mktemp (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-16 13:17 EDT by Michael J. Carter
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 04:53:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael J. Carter 2005-05-16 13:17:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
pnmindex and pnmmargin both call mktemp with the -t option:

carter@willamette$ grep mktemp pnm*
pnmindex:tmpdir=$(mktemp -d -t pi.XXXXXXXX) || exit 1 #219019
pnmmargin:tmpdir=$(mktemp -d -t ppmmargin.XXXXXXX) || exit 1 #219019

but mktemp doesn't accept that option.

Version-Release number of selected component (if applicable):
mktemp-1.5-18

How reproducible:
Always

Steps to Reproduce:
1. cp /usr/share/apps/kspaceduel/sprites/explosion/explos00.pbm /tmp
2. pnmmargin -white 10 /tmp/explos00.pbm
3.
  

Actual Results:  carter@willamette$ pnmmargin -white 10 /tmp/explos00.pbm
mktemp: invalid option -- t
Usage: mktemp [-d] [-q] [-u] template


Expected Results:  pnmmargin should execute without error.

Additional info:
Comment 1 Ngo Than 2005-05-17 04:53:47 EDT

*** This bug has been marked as a duplicate of 133416 ***

Note You need to log in before you can comment on or make changes to this bug.