Bug 1578761 - cloud-config should be null rather than /etc/origin/cloudprovider/.conf in cloud provider not enabled cluster
Summary: cloud-config should be null rather than /etc/origin/cloudprovider/.conf in cl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Russell Teague
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-16 11:23 UTC by Weihua Meng
Modified: 2018-07-30 19:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The variable used for setting the cloud provider had a default value such that the conditional test was not reliable. Both the default value and the conditional were updated to empty strings.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:15:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:54 UTC

Description Weihua Meng 2018-05-16 11:23:37 UTC
Description of problem:
cloud-config should be null or not show up rather than /etc/origin/cloudprovider/.conf in cloud provider not enabled cluster 

Version-Release number of the following components:
openshift-ansible-3.10.0-0.46.0

How reproducible:
Always

Steps to Reproduce:
1. install OCP without cloud provider enabled

Actual results:
# grep -A3 cloud-config /etc/origin/node/node-config.yaml 
  cloud-config:
  - /etc/origin/cloudprovider/.conf
  cloud-provider:
  - 

# systemctl status atomic-openshift-node.service -l | grep cloud
           └─25578 /usr/bin/hyperkube kubelet --v=5 --address=0.0.0.0 --allow-privileged=true --anonymous-auth=true --authentication-token-webhook=true --authentication-token-webhook-cache-ttl=5m --authorization-mode=Webhook --authorization-webhook-cache-authorized-ttl=5m --authorization-webhook-cache-unauthorized-ttl=5m --bootstrap-kubeconfig=/etc/origin/node/bootstrap.kubeconfig --cadvisor-port=0 --cert-dir=/etc/origin/node/certificates --cgroup-driver=systemd --client-ca-file=/etc/origin/node/client-ca.crt --cloud-config=/etc/origin/cloudprovider/.conf --cloud-provider= --cluster-dns=172.16.120.109

Expected results:
cloud-config should be null or not show up

Comment 1 Scott Dodson 2018-05-21 13:28:30 UTC
Need to update node-config template in openshift_node_group role to check for empty string and skip cloud configuration in that situation.

Comment 2 Russell Teague 2018-05-22 12:40:20 UTC
Proposed: https://github.com/openshift/openshift-ansible/pull/8473

Comment 3 Russell Teague 2018-05-24 13:00:39 UTC
openshift-ansible-3.10.0-0.51.0

Comment 4 Weihua Meng 2018-05-27 12:39:22 UTC
Fixed.
openshift-ansible-3.10.0-0.53.0.git.0.53fe016.el7.noarch.rpm

in cloud provider not enabled cluster,
  cloud-config and cloud-provider are not in node-config.yaml 

# cat /etc/redhat-release 
Red Hat Enterprise Linux Atomic Host release 7.5

Kernel Version: 3.10.0-862.el7.x86_64

Comment 6 errata-xmlrpc 2018-07-30 19:15:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.