Bug 1578828 - The validator "Compare switch port VLANs to VLANs in nic config" generates multiple warning
Summary: The validator "Compare switch port VLANs to VLANs in nic config" generates mu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: beta
: 15.0 (Stein)
Assignee: Gaël Chamoulaud
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-16 12:42 UTC by Udi
Modified: 2019-09-26 10:44 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-validations-10.4.1-0.20190621220403.673148d.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:16:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 666603 None None None 2019-06-24 09:17:06 UTC
OpenStack gerrit 666801 None None None 2019-06-21 13:29:18 UTC

Description Udi 2018-05-16 12:42:46 UTC
Description of problem:
When running the validator "Compare switch port VLANs to VLANs in nic config" you get this output:

Task 'Check that switch vlans are present if used in nic-config files' succeeded, but had some warnings:
Host: localhost
Warnings:

* LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
LLDP data not available for node 8c8fb635-4d12-4d19-a7ab-17dc8ae3aa02
Success! The validation passed for all hosts:
* localhost


Version-Release number of selected component (if applicable):
openstack-tripleo-validations-8.4.1-5.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Run this validator on a virt environment, before the deployment


Actual results:
Validator generates multiple warnings on the same node.

Comment 2 Bob Fournier 2018-05-16 22:22:23 UTC
This message will occur if LLDP data from a network switch has not been received, which is normal in virtual environments, and even acceptable in a baremetal setup since switches may be configured to not use LLDP.

I can change this to be an info message.  Also in addition to outputting the node, can addd in the vlan info.  This is printed one time for each vlan checked.

Comment 5 Bob Fournier 2018-09-05 14:38:00 UTC
Hi Beth - I haven't gotten back to this but plan on making a fix.  I've moved it to the HardProv DFG to get it off the UI backlog.

Comment 13 errata-xmlrpc 2019-09-21 11:16:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.