Bug 1578883 - selinux issues with timemaster
Summary: selinux issues with timemaster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-16 14:33 UTC by Miroslav Lichvar
Modified: 2018-10-30 10:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:03:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:04:28 UTC

Description Miroslav Lichvar 2018-05-16 14:33:03 UTC
Description of problem:
When using the timemaster service from the linuxptp package, a shared memory segment is used to exchange measurements between chronyd and ptp4l or phc2sys. The memory segment can be created by any of the three processes. There is a race. Usually it's chronyd what creates the memory segment and that's when it works, but if it's phc2sys or ptp4l, chronyd is not able to get the segment due to a SELinux rule.

type=AVC msg=audit(1525261575.377:77): avc:  denied  { unix_read unix_write } for  pid=1342 comm="chronyd" key=1314148400  scontext=system_u:system_r:chronyd_t:s0 tcontext=system_u:system_r:phc2sys_t:s0 tclass=shm

A similar issue is with segments created by ptp4l (using SW timestamping) when switching to phc2sys (using HW timestamping).

type=AVC msg=audit(1525263148.431:75): avc:  denied  { unix_read unix_write } for  pid=1366 comm="phc2sys" key=1314148401  scontext=system_u:system_r:phc2sys_t:s0 tcontext=system_u:system_r:ptp4l_t:s0 tclass=shm

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-192.el7_5.3.noarch

How reproducible:
sometimes

Steps to Reproduce:
1. remove existing segments (e.g. with ipcrm -M 0x4e545030)
1. start timemaster configured to use at least one PTP source, e.g.
     [ptp_domain 0]
     interfaces eth0
2. check the system log

Actual results:
chronyd[840]: Fatal error : shmget() failed

Expected results:
chronyd running with no AVCs reported in the logs.

Additional info:

Comment 5 errata-xmlrpc 2018-10-30 10:03:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.