Bug 1579153 - Fail to upgrade docker container ocp on atomic hosts at TASK [openshift_node : Install or Update node system container]
Summary: Fail to upgrade docker container ocp on atomic hosts at TASK [openshift_node ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-17 05:59 UTC by liujia
Modified: 2018-07-30 19:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:15:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:03 UTC

Description liujia 2018-05-17 05:59:41 UTC
Description of problem:
Fail to upgrade ocp on atomic hosts at TASK [openshift_node : Install or Update node system container].
TASK [openshift_node : Install or Update node system container] ****************
task path: /usr/share/ansible/openshift-ansible/roles/openshift_node/tasks/node_system_container.yml:28
Thursday 17 May 2018  03:21:46 +0000 (0:01:59.843)       0:12:04.535 ********** 
fatal: [x]: FAILED! => {"changed": false, "failed": true, "msg": "The file /etc/systemd/system/atomic-openshift-node.service already exists.\n", "rc": 1}

Version-Release number of the following components:
ansible-2.4.4.0-1.el7ae.noarch
openshift-ansible-3.10.0-0.47.0.git.0.c018c8f.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Upgrade against docker container ocp on atomic hosts from v3.9 to v3.10
2.
3.

Actual results:
Upgrade failed.

Expected results:
Upgrade succeed.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 Vadim Rutkovsky 2018-05-21 08:23:32 UTC
Fix is available in openshift-ansible-3.10.0-0.48.0

Comment 4 liujia 2018-05-23 05:20:24 UTC
Verified on openshift-ansible-3.10.0-0.50.0.git.0.bd68ade.el7.noarch

Comment 6 errata-xmlrpc 2018-07-30 19:15:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.