Bug 1579247 - [RFE] make ceph_volume_client library python3 compatible
Summary: [RFE] make ceph_volume_client library python3 compatible
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 3.0
Hardware: All
OS: All
high
low
Target Milestone: rc
: 3.2
Assignee: Rishabh Dave
QA Contact: Ramakrishnan Periyasamy
URL:
Whiteboard:
Depends On:
Blocks: 1553198
TreeView+ depends on / blocked
 
Reported: 2018-05-17 09:03 UTC by Ram Raja
Modified: 2019-01-03 19:01 UTC (History)
6 users (show)

Fixed In Version: RHEL: ceph-12.2.8-12.el7cp Ubuntu: ceph_12.2.8-10redhat1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-01-03 19:01:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 26851 None None None 2018-08-03 21:14:45 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:01:45 UTC

Description Ram Raja 2018-05-17 09:03:48 UTC
Description of problem:
The ceph_volume_client python library used by OpenStack Manila is not py3 compliant. It needs to be py3 compliant in time for OSP 14 release, in which Manila's CephFS drivers would use ceph_volume_client library in py2 and py3 environments. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 11 Ramakrishnan Periyasamy 2018-11-23 11:19:38 UTC
Hi  Rishabh, 
We are not having python3 environment in downstream teuthology, Did we tested this in upstream teuthology with python3 env ? and if tests all passed in upstream, we would like to close this bz as SanityOnly. Let us know your comments.

Comment 12 Patrick Donnelly 2018-11-26 23:31:04 UTC
We've tested this in upstream regularly. We can close this SanityOnly IMO.

Comment 14 Ramakrishnan Periyasamy 2018-11-28 06:17:10 UTC
Thanks Patrick for the suggestion.

Moving this bug to verified state as SanityOnly as per comment 11 & 12.

Comment 16 errata-xmlrpc 2019-01-03 19:01:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.