Bug 1579257 - System boots to blank screen when Xinerama enabled with nvidia/nouveau driver
Summary: System boots to blank screen when Xinerama enabled with nvidia/nouveau driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.5
Hardware: Unspecified
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Jonas Ådahl
QA Contact: Desktop QE
Tomas Capek
URL:
Whiteboard:
Depends On:
Blocks: 1714959
TreeView+ depends on / blocked
 
Reported: 2018-05-17 09:15 UTC by Divya
Modified: 2019-08-15 16:43 UTC (History)
10 users (show)

Fixed In Version: mutter-3.28.3-9.el7
Doc Type: Bug Fix
Doc Text:
.System no longer boots to a blank screen when Xinerama is enabled When the Xinerama extension was enabled in `/etc/X11/xorg.conf` on a system using the nvidia or nouveau driver, the RANDR X extension got disabled. Consequently, login screen failed to start upon boot due to the RANDR X extension being disabled. This bug has been fixed and the login screen now starts properly even with Xinerama enabled.
Clone Of:
: 1714959 (view as bug list)
Environment:
Last Closed: 2019-08-06 12:37:16 UTC


Attachments (Terms of Use)
Mutter patches for rhel 7.5 (8.54 KB, patch)
2018-10-05 15:39 UTC, Jonas Ådahl
no flags Details | Diff
Mutter patches for rhel 7.6 (9.98 KB, patch)
2018-10-05 15:40 UTC, Jonas Ådahl
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2044 None None None 2019-08-06 12:38:31 UTC

Description Divya 2018-05-17 09:15:30 UTC
Description of problem:

Version-Release number Description of problem:
System booted to runlevel 5, with Xinerama enabled in Xorg.conf with either nvidia or nouveau driver gets stuck with blank screen. Tests are done with below mentioned cards: 

VGA compatible controller: NVIDIA Corporation GK107GL [Quadro K2000] (rev a1)

VGA compatible controller [0300]: NVIDIA Corporation GK107 [GeForce GT 640] [10de:0fc1] (rev a1) (prog-if 00 [VGA controller])

VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)


Version-Release number of selected component (if applicable):
gdm-3.26.2.1-5.el7

How reproducible:
Always

Steps to Reproduce:
1. On a system with nvidida card, configure X to enable Xinerama with nvidia/nouveau driver
2. Boot the system to runlevel 5


Actual results:
It never presents a login screen, instead presents a blank screen.

Expected results:
Botted in runlevel 5, it should prompt login screen to allow user to initiate session.

Additional info:
We test this on both Fedora 27 and Fedodar 28 as well but no luck, still the same result. of selected component (if applicable):

Comment 1 Divya 2018-05-17 09:38:08 UTC
I missed an important piece of information here, i.e  With LightDM all worked as expected with Xinerama enabled.

Comment 7 customercare 2018-06-22 21:05:28 UTC
could it be, that your monitors.xml file is not setup correctly to end up having your login screen on the wrong display ? 

Once you logged into your gdm session, configure your monitor setup and 

 copy the monitors.xml file :

cp ~/.config/monitors.xml /var/lib/gdm/.config/

I had the same problem and this fixed it.

Comment 12 Jonas Ådahl 2018-10-03 12:35:24 UTC
I have a scratch build for 7.5 that tries to somewhat handle the lack of RANDR support in the X server by assuming the whole screen is a single dummy monitor. I can start GNOME Shell with this on a dual monitor setup and it'll work as if all connected monitors were just a single one. Naturally monitor configuration does no longer work with this.

Is this something that would work for the customer?

The scratch build is available here:
http://brew-task-repos.usersys.redhat.com/repos/scratch/jadahl/mutter/3.26.2/18.el7_5/

Comment 13 Jonas Ådahl 2018-10-03 13:21:41 UTC
A scratch build for 7.6 available here:
http://brew-task-repos.usersys.redhat.com/repos/scratch/jadahl/mutter/3.28.3/5.el7/

Comment 14 Jonas Ådahl 2018-10-05 15:39:20 UTC
Created attachment 1490887 [details]
Mutter patches for rhel 7.5

Comment 15 Jonas Ådahl 2018-10-05 15:40:10 UTC
Created attachment 1490888 [details]
Mutter patches for rhel 7.6

Comment 17 Jonas Ådahl 2018-10-10 18:40:56 UTC
Here is another scratch build for 7.5. I have tested this on a system with nvidia, with two (separate) monitors using a config similar to the ones in the sosreports. The previous version did indeed crash when using the nvidia driver, but not in the driver as reported reported above, so I cannot verify the same crash is fixed.

The new coredump tarball also seems to not have contained any mutter or gnome-shell backtraces, so if the new scratch build still causes a crash, it'd be very useful to have the whole backtrace leading up to the crash.

Here is the new scratch build:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=18723238

Comment 18 Divya 2018-10-12 10:14:30 UTC
Feedback from the customer with latest scratch build

*******
THAT WORKED!!!!!! I did see some core dumps. I didn't always get them when I booted up but I did get a few. They are attached. I tested with Xinerama disabled and enabled, both with 1 screen attached and 2 screens attached. It worked as desired in all 4 cases, but most importantly it worked in the desired case of 2 screens attached with Xinerama enabled.
*******

In the attached coredumps, I see, two of them belongs to gnome-shell.

Comment 19 Jonas Ådahl 2018-10-12 12:36:50 UTC
Great, thanks a lot for testing!

Comment 30 errata-xmlrpc 2019-08-06 12:37:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2044


Note You need to log in before you can comment on or make changes to this bug.